[Dogfood] [PP] Application crash when user dismiss an Alert box

VERIFIED FIXED in M13

Status

MailNews Core
Composition
P3
critical
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Jean-Francois Ducarroz, Assigned: saari (gone))

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
If message send failed, an alert is shown. When you click on the button ok,
Mozilla crash when trying to showing back the compose window.
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: Application crash if send op. failed and user ask back the compose window → [Dogfood] Application crash if send op. failed and user ask back the compose window
Target Milestone: M13

Updated

19 years ago
QA Contact: lchiang → laurel

Updated

19 years ago
Whiteboard: [PDT+]

Comment 1

19 years ago
PDT+
(Reporter)

Comment 2

19 years ago
Here is the easy steps to reproduce the crash:

1) start Messenger
2) Open the account setup (menu edit/Account Setup)
3) Select "Outgoing (SMTP) server" and clear the smtp  server name
4) Close the Account Setup by pressing the OK button
5) Create a new message and send it
6) >>> The compose window still there and a error box popup in the front of it
7) Press OK in the Error box
8) >>> CRASH
(Reporter)

Updated

19 years ago
Summary: [Dogfood] Application crash if send op. failed and user ask back the compose window → [Dogfood] [PP] Application crash if send op. failed and user ask back the compose window
(Reporter)

Comment 3

19 years ago
Windows doesn't have this problem. Haven't tested on Linux.
(Reporter)

Comment 4

19 years ago
Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  179346A0
  045E7240    PPC  1792EE78  main+00194
  045E71B0    PPC  1792D76C  main1(int, char**)+006AC
  045E70D0    PPC  1600313C  nsAppShellService::Run()+00020
  045E7090    PPC  15F9B67C  nsAppShell::Run()+00050
  045E7010    PPC  15F9BF3C  nsMacMessagePump::DoMessagePump()+00044
  045E6FC0    PPC  15F9C154  nsMacMessagePump::DispatchEvent(int, EventRecord*)+00098
  045E6F70    PPC  15F9CB40  nsMacMessagePump::DoMouseUp(EventRecord&)+00050
  045E6F20    PPC  15F9D0E8  nsMacMessagePump::DispatchOSEventToRaptor(EventRecord&, GrafPort*)+0004C
  045E6ED0    PPC  15F96888  nsMacMessageSink::DispatchOSEvent(EventRecord&, GrafPort*)+00048
  045E6E90    PPC  15F8F234  nsMacWindow::HandleOSEvent(EventRecord&)+0004C
  045E6E30    PPC  15F90170  nsMacEventHandler::HandleOSEvent(EventRecord&)+000D0
  045E6DE0    PPC  15F91AFC  nsMacEventHandler::HandleMouseUpEvent(EventRecord&)+000C4
  045E6D50    PPC  15F74D20  nsWindow::DispatchMouseEvent(nsMouseEvent&)+00060
  045E6CF0    PPC  15F74BBC  nsWindow::DispatchWindowEvent(nsGUIEvent&)+00028
  045E6CB0    PPC  15F74AC8  nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&)+000A8
  045E6C60    PPC  15410478  HandleEvent(nsGUIEvent*)+10478
  045E6C10    PPC  1540C5A0  nsViewManager::DispatchEvent(nsGUIEvent*, nsEventStatus*)+0C5A0
  045E6A10    PPC  154124BC  nsView::HandleEvent(nsGUIEvent*, unsigned int, nsEventStatus*, int&)+124BC
  045E6990    PPC  1562633C  PresShell::HandleEvent(nsIView*, nsGUIEvent*, nsEventStatus*)+2633C
  045E6920    PPC  156E9870  nsEventStateManager::PostHandleEvent(nsIPresContext*, nsGUIEvent*, nsIFrame*,
nsEventStatus*, nsIView*)+E9870
  045E6770    PPC  156EBF48  nsEventStateManager::CheckForAndDispatchClick(nsIPresContext*, nsMouseEvent*,
nsEventStatus*)+EBF48
  045E66C0    PPC  15EEF738  nsXULElement::HandleDOMEvent(nsIPresContext*, nsEvent*, nsIDOMEvent**, unsigned
int, nsEventStatus*)+EF738
  045E6530    PPC  156E4C14  nsEventListenerManager::HandleEvent(nsIPresContext*, nsEvent*, nsIDOMEvent**,
unsigned int, nsEventStatus*)+E4C14
  045E63A0    PPC  156E45A8  nsEventListenerManager::HandleEventSubType(nsListenerStruct*, nsIDOMEvent*,
unsigned int)+E45A8
  045E6180    PPC  161166D4  nsJSEventListener::HandleEvent(nsIDOMEvent*)+001EC
  045E6060    PPC  1608A464  nsJSContext::CallEventHandler(void*, void*, unsigned int, void*, int*)+002C4
  045E5FC0    PPC  162A13D8  JS_CallFunctionValue+00040
  045E5F80    PPC  162BF200  js_InternalCall+000CC
  045E5ED0    PPC  162BEF54  js_Invoke+0094C
  045E5DD0    PPC  162C7B10  js_Interpret+08038
  045E5A70    PPC  162BEF54  js_Invoke+0094C
  045E5970    PPC  162C7B10  js_Interpret+08038
  045E5610    PPC  162BEF54  js_Invoke+0094C
  045E5510    PPC  162C7B10  js_Interpret+08038
  045E51B0    PPC  162BEEF0  js_Invoke+008E8
  045E50B0    PPC  15E087C8  WrappedNative_CallMethod(JSContext*, JSObject*, unsigned int, long*, long*)+087C8
  045E5030    PPC  15E06770  nsXPCWrappedNativeClass::CallWrappedMethod(JSContext*, nsXPCWrappedNative*,
const XPCNativeMemberDescriptor*, nsXPCWrappedNativeClass::CallMode, unsigned int, long*, long*)+06770
  045E4DB0    PPC  1624C200  XPTC_InvokeByIndex+0002C
  045E4D70    PPC  1624C308  _XPTC_InvokeByIndex+000C8
  045E4CC0    PPC  1776F938  nsMsgCompose::SendMsg(int, nsIMsgIdentity*, const unsigned short*)+6F938
  045E4B00    PPC  1776F4F4  nsMsgCompose::_SendMsg(int, nsIMsgIdentity*, const unsigned short*)+6F4F4
  045E48B0    PPC  17741E80  nsMsgComposeAndSend::CreateAndSendMessage(nsIEditorShell*, nsIMsgIdentity*,
nsIMsgCompFields*, int, int, int, nsIMessage*, const char*, const char*, unsigned int, const nsMsgAttachmentData*,
const nsMsgAttachedFile*, void*, nsIMsgSendListener**+41E80
  045E4840    PPC  1773E648  nsMsgComposeAndSend::Init(nsIMsgIdentity*, nsMsgCompFields*, nsFileSpec*, int, int,
int, nsIMessage*, const char*, const char*, unsigned int, const nsMsgAttachmentData*, const nsMsgAttachedFile*)+
3E648
  045E47C0    PPC  1773D37C  nsMsgComposeAndSend::HackAttachments(const nsMsgAttachmentData*, const
nsMsgAttachedFile*)+3D37C
  045E4700    PPC  17737510  nsMsgComposeAndSend::GatherMimeAttachments()+37510
  045E4480    PPC  1773EDDC  nsMsgComposeAndSend::DeliverMessage()+3EDDC
  045E4400    PPC  1773F9E0  nsMsgComposeAndSend::DeliverFileAsMail()+3F9E0
  045E42A0    PPC  1774CFE4  nsSmtpService::SendMailMessage(nsIFileSpec*, const char*, nsIMsgIdentity*,
nsIUrlListener*, nsISmtpServer*, nsIURI**)+4CFE4
  045E41F0    PPC  1774D574  NS_MsgLoadSmtpUrl(nsIURI*, nsISupports*)+4D574
  045E4180    PPC  1774B798  nsSmtpProtocol::LoadUrl(nsIURI*, nsISupports*)+4B798
  045E40A0    PPC  1777FE04  nsMsgMailNewsUrl::SetUrlState(int, unsigned int)+7FE04
  045E4030    PPC  155656B0  nsUrlListenerManager::OnStopRunningUrl(nsIMsgMailNewsUrl*, unsigned int)+656B0
  045E3FF0    PPC  1556540C  nsUrlListenerManager::BroadcastChange(nsIURI*, nsUrlNotifyType, unsigned int)+
6540C
  045E3F50    PPC  1775FF2C  nsMsgDeliveryListener::OnStopRunningUrl(nsIURI*, unsigned int)+5FF2C
  045E3EE0    PPC  1773E9F0  MailDeliveryCallback(nsIURI*, unsigned int, void*)+3E9F0
  045E3E90    PPC  17740A00  nsMsgComposeAndSend::DeliverAsMailExit(nsIURI*, unsigned int)+40A00
  045E3E50    PPC  1774073C  nsMsgComposeAndSend::DoDeliveryExitProcessing(unsigned int, int)+4073C
  045E3DD0    PPC  17741594  nsMsgComposeAndSend::NotifyListenersOnStopSending(const char*, unsigned int,
const unsigned short*, nsIFileSpec*)+41594
  045E3D80    PPC  177737BC  nsMsgComposeSendListener::OnStopSending(const char*, unsigned int, const unsigned
short*, nsIFileSpec*)+737BC
  045E3D30    PPC  17770108  nsMsgCompose::ShowWindow(int)+70108
  045E3CF0    PPC  1600F524  nsWebShellWindow::Show(int)+001A8
  045E3C40    PPC  160A42D0  GlobalWindowImpl::Focus()+001A4
  045E3BE0    PPC  15F721A8  nsWindow::SetFocus()+00018
  045E3BA0    PPC  15F8FA0C  nsMacEventDispatchHandler::SetFocus(nsWindow*)+00040
  045E3B60    PPC  15F761A4  nsWindow::ResetInputState()+00024
(Reporter)

Updated

19 years ago
Assignee: ducarroz → saari
Status: ASSIGNED → NEW
(Reporter)

Comment 5

19 years ago
looks like a problem with SetFocus or ResetInputState. Reassign to saari.
(Reporter)

Updated

19 years ago
Summary: [Dogfood] [PP] Application crash if send op. failed and user ask back the compose window → [Dogfood] [PP] Application crash when user dismiss an Alert box
(Reporter)

Comment 6

19 years ago
I've just reproduced this problem with the browser window when you try to load
an url without be connected to the net.

1) Remove you ethernet cable
3) Start Mozilla (without any argument)
4) Wait for browser to through an alert (about 1 minute)
5) Dismiss the Alert
6) ==> crash (in nsWindow::ResetInputState)

Comment 7

19 years ago
cc: paulmac for browser case.
(Reporter)

Comment 8

19 years ago
I also see the problem when I open the account setup dialog (from the mailnews 3panes window), selct the smtp
server and the click cancel.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
Fixed, the focus code was fogetting to do a release, and a leaf window's parent
chain would be deleted, but not the leaf, so when we interacted with it later, it
would die when referencing its parent.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
OK using 2000-01-20-08m13 commercial build on linux 6.0
OK using 2000-01-20-08m13 mozilla build on mac os 8.5.1.

Updated

19 years ago
Blocks: 24854
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.