Closed Bug 23982 Opened 20 years ago Closed 20 years ago

Editing focus problem in INPUT fields

Categories

(Core :: XUL, defect, P3)

x86
Other
defect

Tracking

()

VERIFIED DUPLICATE of bug 12051

People

(Reporter: sas, Assigned: leger)

References

()

Details

OS: WinNT 4.0 SP4+
Machine: HP VA, 200MHz, 64MB
Mozilla build: M12
Build-id:
1999122923

How to reproduce:
1) Open a dos window (any other application would
do, just for
   switching to another window, required for test case below)
1)
Open URL
http://www.google.com/
2) Click on the query input field and type a
word, say, "mozilla "
3) Use ALT-TAB to switch to other application (dos window)
4) Again use ALT-TAB to switch back to Mozilla
5) Try to continue to type the
query string
6) PROBLEM: The focus is no longer in the query input field
7) The
query string you try to input would be taken as menu commands
8) Using mouse
click on the query input field
9) Continue tying, say, "editor"
10) PROBLEM: The
key stroke "e" would appear in the query window
    as well as it would be taken
as menu command "Edit" and the
    Edit menu appears

What should have happened:
1) In point (6) above, the foucs should have remained in query input field
2) In
point (10) above keystrokes should not be taken as menu short cut kesy
The foucs not going back to the correct input box (point 6) sounds like bug 
12051. The fact that it is activatiing the menus (point 10) seems like bug 
18598.

I'm setting the component to XP Toolkit/Widgets because the main complaint is 
about the INPUT field...
Component: Browser-General → XP Toolkit/Widgets
Assigning all open "nobody@mozilla.org" bugs to "leger@netscape.com" to weed 
thru.
Assignee: nobody → leger
Marking this a dup of bug 12051, since the other one's fixed.

*** This bug has been marked as a duplicate of 12051 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.