Download Manager won't recognize a download is done loading

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
--
critical
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Keith Gallistel, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

When I download a file off the internet and then download it again because I
forget to save it to a file after deleting file from download manager list, the
download manager gets "stuck".  It shows that the file is tranferred and
finished at 100%, but when I click to remove it only gives me the options of
"properties" or "cancel".  When I right click on and choose "properties", all it
gives me is the options to "cancel" or "pause"/"resume" but I can never remove
the file from the download manager.  Also, even though the download manager
shows that the file is completely downloaded, it continues to "elapse" time in
the "saving" window even though the progress bar is not filling up.

Reproducible: Always
Steps to Reproduce:
1.go to any website
2.download a file completely
3.delete same file from download manager window
4.download same file completely again

Actual Results:  
The download manager becomes stuck and I can only use the "properties" or
"cancel" buttons and the "cancel" button doesn't cancel the download.

Expected Results:  
Either Recognized that the file is still in the "temp folder" and open it or
should download file again and overwrite one in "temp file".  In either case, I
should still be allowed to remove file from list after I'm done saving said file.

Updated

14 years ago
Assignee: general → download-manager
Component: Browser-General → Download Manager

Comment 1

14 years ago
WFM (cannot reproduce it) with a current CVS based trunk homemade build under WinXP.

-> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040407

Reporter. When this happens, can you go to tools / Web Development / Javascript
Console and see if there is a an error ?

Also, which theme are you using ?
(Reporter)

Comment 2

14 years ago
I turned on JavaScript Console as asked.  Then I got the error to occur again by
going to http://www.geocities.com/beigetangerine/ and downloading, deleting from
from download manager, and redownloading "BGII: SoA Item Location List" at
"http://www.geocities.com/beigetangerine/itemlist.xls".  Finally, I then went to
the JavaScript Console and found these two error messages:

1)

Error: this.doc.getElementById(aDownloadID) has no properties
Source File:
file:///C:/Program%20Files/mozilla.org/Mozilla/components/nsDownloadProgressListener.js
Line: 105

This error message had this piece of code highlighted when I clicked on it:

      var elt = this.doc.getElementById(aDownloadID).firstChild.firstChild;


2)

Error: this.doc.getElementById(aDownloadID) has no properties
Source File:
file:///C:/Program%20Files/mozilla.org/Mozilla/components/nsDownloadProgressListener.js
Line: 63

This error message had this piece of code highlighted when I clicked on it:

        var elt = this.doc.getElementById(aDownloadID).firstChild.firstChild;

Hopefully this helps you.
Product: Browser → Seamonkey

Comment 3

12 years ago
Reporter, does this still happen with a current SeaMonkey build?

Comment 4

12 years ago
WFM with 2005-11-09 trunk nightly. Reporter: Comment again if you still see this happening.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.