Stopped downloads due to duplicate harddisk usage (temp + target dir), can't change temp dir

VERIFIED DUPLICATE of bug 69938

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 69938
15 years ago
2 years ago

People

(Reporter: Matthias Buecher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

When downloading cd images (debian/suse) or big addons (400-600MB) for games,
e.g. Desert Combat for BF1942, these downloads stop because with a "not enough
space" error, although the target directory (D:\DOWNLOAD) has 20.0 GB free.
Reason for this behaviour is that Mozilla wastes harddisk space while
downloading a file, as the file is downloaded to the system's temporary
directory *AND* to the target directory.
My system partition has "only" 400MB free, so those huge files won't fit into
C:\WINDOWS\TEMP.



Reproducible: Always
Steps to Reproduce:
1. Find a file that's bigger than the free space of the drive where your Windows
TEMP dir is located
- OR -
create a big huge file to fill up your Windows TEMP dir so your download test
file won't fit in anymore. Use "fsutil file createnew DUMMY.XYZ <size in bytes>"
(W2K/WXP only) to create a huge dummy file.
2. Start downloading your test file.


Expected Results:  
Files should be downloaded directly to the target directory, maybe with the
addition ".incomplete" which could be renamed after a successful download.
If "double downloading" is necessary then the temporary download directory
should be configurable similar to "browser.cache.disk.parent_directory".
Mozilla could do a size-check on the target (and temp) directory before
downloading, so the download won't stop suddenly after an hour although it was
foreseeable.

Comment 1

15 years ago
Please search for duplicates before filing new bug reports. Thanks!

*** This bug has been marked as a duplicate of 69938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: Download Manager → File Handling
OS: Windows XP → All
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.