If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"users who are a" is awkward and should be rewritten

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
Administration
--
trivial
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: timeless, Assigned: Shane H. W. Travis)

Tracking

2.17.6
Bugzilla 2.20
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

2.80 KB, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
Actual Text:
Bugs in this product are permitted to be restricted to this group. Users who are
a member of this group will be able to place bugs in this group. Non-members
will be forced to restrict bugs to this group when they initially enter a bug in
this product.

--
'Users' is plural, so it should be 'Users who are members'

Comment 1

14 years ago
Created attachment 149753 [details] [diff] [review]
Fix per timeless's suggestion
Assignee: justdave → vladd
Status: UNCONFIRMED → ASSIGNED

Updated

14 years ago
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18

Updated

14 years ago
Attachment #149753 - Flags: review?(bugreport)

Comment 2

14 years ago
Comment on attachment 149753 [details] [diff] [review]
Fix per timeless's suggestion

I don't even want to think about why this is repeated five times in the same
file.. 

-- Kiko "templatization now!"
Attachment #149753 - Flags: review+

Updated

14 years ago
Attachment #149753 - Flags: review?(bugreport)

Updated

14 years ago
Flags: approval?
Reasonable polish. a=myk
Flags: approval? → approval+

Comment 4

14 years ago
Checking in editproducts.cgi;
/cvsroot/mozilla/webtools/bugzilla/editproducts.cgi,v  <--  editproducts.cgi
new revision: 1.50; previous revision: 1.49
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

13 years ago
unfortunately, this got stomped in some way by bug 147275 (templatization now)

	Regular Expression Search
Users who are a member
/webtools/bugzilla/template/en/default/admin/products/groupcontrol/edit.html.tmpl,
line 182 -- group. Users who are a member of this group will be able to place [%
terms.bugs %] in
/webtools/bugzilla/template/en/default/admin/products/groupcontrol/edit.html.tmpl,
line 221 -- group. Users who are a member of this group will be able to place [%
terms.bugs %]
/webtools/bugzilla/template/en/default/admin/products/groupcontrol/edit.html.tmpl,
line 235 -- group and are placed in this group by default. Users who are a
member of this
/webtools/bugzilla/template/en/default/admin/products/groupcontrol/edit.html.tmpl,
line 248 -- group and are placed in this group by default. Users who are a
member of this group
/webtools/bugzilla/template/en/default/admin/products/groupcontrol/edit.html.tmpl,
line 262 -- group and are placed in this group by default. Users who are a
member of this group

This page was automatically generated by LXR. 
Status: RESOLVED → UNCONFIRMED
Depends on: 147275
Resolution: FIXED → ---
(In reply to comment #5)
> unfortunately, this got stomped in some way by bug 147275 (templatization now)

uh, doubtful.  The patch on that bug was committed two years prior to this one.

Looks like that patch forgot to remove unneeded stuff from editproducts.cgi, and
the patch on this bug edited the stuff in editproducts instead of the stuff in
the template.
yep, confirmed.  The patch that was checked in on this bug was a no-op.  You
patched "commented-out" code. :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: approval+
(Assignee)

Comment 8

13 years ago
This was checked in a long time ago, with the message:

revision 1.50
date: 2004/06/01 21:30:29;  author: jocuri%softhome.net;  state: Exp;  lines: 
+5 -5
Patch for bug 240252: rewrite "users who are a" on editproducts.cgi; r=kiko; 
a=myk.

Changing the statsus to RESOLVED/FIXED to reflect that reality.
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

13 years ago
nope. see conversation.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

13 years ago
Created attachment 174485 [details] [diff] [review]
Code patch for tip

Fixes this in the right place.

Also adds a warning to the table that isn't part of this bug (I know) but which
has been on my mind to add for quite some time, and I keep forgetting to file a
separate bug about it. Since they're both non-code changes this passed my
personal acceptability radar, but if doing two things in one bug really wigs
you out, r- the patch and I'll split them.
Assignee: vladd → travis
Attachment #149753 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
(Assignee)

Updated

13 years ago
Attachment #174485 - Flags: review?(mkanat)

Comment 11

13 years ago
Comment on attachment 174485 [details] [diff] [review]
Code patch for tip

Wow, I totally agree with having that warning there, too. I won't object for
this one instance. :-)

r=mkanat by inspection
Attachment #174485 - Flags: review?(mkanat) → review+

Updated

13 years ago
Flags: approval?
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Flags: approval? → approval+
(Assignee)

Comment 12

13 years ago
Checking in template/en/default/admin/products/groupcontrol/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/products/groupcontr
ol/edit.html.tmpl,v  <--  edit.html.tmpl
new revision: 1.5; previous revision: 1.4
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.