Last Comment Bug 240272 - prefLabel should be saved in the 'native' code in registry (bug 232969) patch
: prefLabel should be saved in the 'native' code in registry (bug 232969) patch
Status: RESOLVED FIXED
: fixed-aviary1.0, intl
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
P3 normal (vote)
: ---
Assigned To: Jungshik Shin
:
:
Mentors:
: 237922 (view as bug list)
Depends on: mzlu
Blocks: 241602
  Show dependency treegraph
 
Reported: 2004-04-11 16:59 PDT by Jungshik Shin
Modified: 2004-08-17 11:20 PDT (History)
9 users (show)
bugs: blocking‑aviary1.0PR+
bugs: blocking‑aviary1.0+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (8.47 KB, patch)
2004-06-24 17:16 PDT, Jungshik Shin
no flags Details | Diff | Splinter Review
update (8.05 KB, patch)
2004-06-25 01:41 PDT, Jungshik Shin
bryner: review+
Details | Diff | Splinter Review
patch checked in with the fix for off-by-two errors (7.01 KB, patch)
2004-07-28 23:01 PDT, Jungshik Shin
no flags Details | Diff | Splinter Review
fix for the off-by-two error (against the trunk) (1.42 KB, patch)
2004-07-28 23:05 PDT, Jungshik Shin
bugs: review+
Details | Diff | Splinter Review
for aviary 1.0 branch (8.27 KB, patch)
2004-08-09 23:28 PDT, Jungshik Shin
no flags Details | Diff | Splinter Review

Description User image Jungshik Shin 2004-04-11 16:59:22 PDT
While waiting for sr in bug 232969, firefox code has changed. I'm filing a new
bug on the issue for firefox alone.
Comment 1 User image Isaac Hwak Han 2004-04-13 05:37:28 PDT
*** Bug 237922 has been marked as a duplicate of this bug. ***
Comment 2 User image Hidehiro Kozawa 2004-06-15 07:28:08 PDT
We have to change
browser\components\shell\src\nsWindowsShellService.cpp
All regkey functions use const char* :(
I wish someone to make it like
http://bugzilla.mozilla.org/attachment.cgi?id=144288&action=view ...
Comment 3 User image Masayuki Nakano [:masayuki] 2004-06-15 07:43:31 PDT
I'm changing Requestee to "?".

This bug is important for non-ASCII environment.
And I think this is fixed easy.
Comment 4 User image Jungshik Shin 2004-06-15 09:13:09 PDT
I'll make sure this will be fixed in 1.0. I can make an ad-hoc patch  rather
easily, but I'm a bit reluctant to duplicate quite a lot of code. This bug is
one of bugs that involves 'A' APIs vs 'W' APIs (see bug 162361 for the most
prominent example) and we need to make a decision as to what to do (keep on
adding ad-hoc patches or assume that MSLU is available everywhere and turn to
'W' APIs once and for all). Judging from the way bug 162361 has been handled so
far, I guess I have to resort to 'the old trick' once more here. 

Comment 5 User image Jungshik Shin 2004-06-24 07:39:10 PDT
I can fix this bug the way I fixed bug 232969, but if we can take advantage of
MSLU, it will simplify things greatly. 
Comment 6 User image Masayuki Nakano [:masayuki] 2004-06-24 10:23:07 PDT
I agree to make advanced mechanism for Unicode.
But I don't think that Bug 239279 will be able to be fixed before firefox 1.0.
Firefox 1.0 should not have this bug.

This bug is _not_ major. However I think that this bug is important.
Such bugs give the wrong impression to non-ASCII users.
# Such bugs are very conspicuous.

I hope this bug is fixed before '1.0'.
Even if the patch is not best.
Comment 7 User image Jungshik Shin 2004-06-24 10:41:25 PDT
While trying to fix bug 239279, I'll make a _minimal_ patch for this bug that
will make Japanese characters work under Japanese locale (but not under
non-Japanese locale, e.g. French locale). 
Comment 8 User image Jungshik Shin 2004-06-24 17:16:49 PDT
Created attachment 151651 [details] [diff] [review]
patch 

This patch makes Japanese string work on Japanese windows but non on French
Windows. For that, I need to do one of two: 1) detect the OS (win2k/xp vs
Win9x/ME) and use either 'A' or 'W' APIs accordingly (as was done in bug
232969) 2) use 'W' APIs exclusively assuming MSLU is present (see bug 239279).
I prefer the latter to the former, but that means I have to wait until bug
239279 is resolved. In the mean time, this patch should cover important cases.
Comment 9 User image Jungshik Shin 2004-06-24 17:18:19 PDT
Nakano-san, can you test my patch on Windows XP? If you can't build, can you ask
someone else at mozilla-jp to build and test it? 

Comment 10 User image Masayuki Nakano [:masayuki] 2004-06-24 20:56:04 PDT
O.K.
Please wait.
Comment 11 User image Jungshik Shin 2004-06-25 01:41:37 PDT
Created attachment 151672 [details] [diff] [review]
update 

I'm sorry there was a mistake in the previous patch although it may have just
worked. Please, try this one instead.
Comment 12 User image Masayuki Nakano [:masayuki] 2004-06-25 20:40:30 PDT
I tested.
JLP for 0.9.1-branch-build doesn't exist, and so I rewrite
'en-US\browser\shellservice.properties' directly.

In this case, the patch works fine.
Comment 13 User image Jungshik Shin 2004-06-25 22:56:16 PDT
Comment on attachment 151672 [details] [diff] [review]
update 

asking for r.
This should also go in for 0.9branch as well as aviary-1.0 branch
Comment 14 User image Jungshik Shin 2004-07-06 11:25:47 PDT
Comment on attachment 151672 [details] [diff] [review]
update 

let's try Blake for r.
Comment 15 User image Jungshik Shin 2004-07-20 18:21:23 PDT
Comment on attachment 151672 [details] [diff] [review]
update 

one more try.
Comment 16 User image Brian Ryner (not reading) 2004-07-22 12:02:03 PDT
Comment on attachment 151672 [details] [diff] [review]
update 

s/For the now/For now/ and r=bryner.
Comment 17 User image Jungshik Shin 2004-07-28 23:01:39 PDT
Created attachment 154624 [details] [diff] [review]
patch checked in with the fix for off-by-two errors 

The current tree has the following:

exeName = Substring(appPath, n + 1, appPath.Length() - (n - 1));

where 'n' is the offset of the last '\' in appPath. I didn't change it in my
patch (attachment 151672 [details] [diff] [review]).  However, it seems that there is an off-by-two
error. The above line should be

exeName = Substring(appPath, n + 1, appPath.Length() - (n + 1));

Perhaps, we're lucky not to have any trouble so far.
Comment 18 User image Jungshik Shin 2004-07-28 23:05:50 PDT
Created attachment 154626 [details] [diff] [review]
fix for the off-by-two error (against the trunk)

this contains the fix for the off-by-two error only (against the trunk). 

attachment 151672 [details] [diff] [review] + this patch + caling sequence change for SetRegKey
introduced on June 30th = attachment 154624 [details] [diff] [review]

Just in case I'm missing something, Nakano-san, can you apply this to the trunk
source and see if it works well.
Comment 19 User image chris hofmann 2004-08-02 11:07:52 PDT
is this fix ready for the aviary branch?  -thx
Comment 20 User image Jungshik Shin 2004-08-02 11:19:48 PDT
Comment on attachment 154626 [details] [diff] [review]
fix for the off-by-two error (against the trunk)

asking for r.
this should be the right thing to do.
Comment 21 User image Ben Goodger (use ben at mozilla dot org for email) 2004-08-09 16:45:35 PDT
Comment on attachment 154626 [details] [diff] [review]
fix for the off-by-two error (against the trunk)

r=ben@mozilla.org

jshin, which of these patches are landed on the aviary br? can you land asap?
Comment 22 User image Jungshik Shin 2004-08-09 23:28:11 PDT
Created attachment 155661 [details] [diff] [review]
for aviary 1.0 branch

There have been  a couple of trivial changes due to which attachment 154624 [details] [diff] [review]
can't be applied cleanly to aviary 1.0 branch.

This should just work, but I'm away from my Windows 2k box so that I can't
compile it (I don't have an XP so that I can test it). Nakano-san, can you test
it on aviary-1.0 branch on Windows XP? 
If I dont' hear from you until 7:59am US PDT  Tuesday(= 11:59 pm +0900/JST/KST
Tuesday), I'll just go ahead.
Comment 23 User image Jungshik Shin 2004-08-11 02:47:11 PDT
checked into aviary-1.0 branch

Note You need to log in before you can comment on or make changes to this bug.