Closed Bug 240314 Opened 16 years ago Closed 16 years ago

Mozilla/Linux does not load applet when width=0 or height=0

Categories

(Core Graveyard :: Java: OJI, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 188454

People

(Reporter: efischer, Assigned: yuanyi21)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Any applet defined with WIDTH=0 or HEIGHT=0 does not load, setting it to 1 
works.

This only occurs with Mozilla for Linux, same Mozilla version on Windows works 
fine. Both running JDK 1.4.2_03.

This code below does not load the applet in Mozilla/Linux.
<HTML>
<HEAD>
</HEAD>
<BODY>
<applet codebase="http://java.sun.com/applets/jdk/1.4/demo/applets/Clock" 
code="Clock.class" width=0 height=0>
</applet>
</BODY>
</HTML>

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Almost sounds like a feature (what's the use of a java applet that cannot be seen?)
There are applets that do not show on screen they run on the background and we 
communicate with them using Javascript (LiveConnect).

One example is InterSystems cspbroker.class applet that permits the browser to 
exchange data with a database behind the scenes. As this applet runs on the 
background I must define WIDTH=0 and HEIGHT=0. This works with IE and 
Mozilla/Windows but fails with Mozilla/Linux, the applet is not loaded.
Whiteboard: DUPEME
Bug 188454 is about supporting relative width/height applet. They are not
exactly same in the first look, but the root causes are same: in the reflow
procedure of relative width/height applet, mozilla will pass some intermedial
zero width/height value to applet, in some version of JRE, it will bypass all
the zero value. But in newest JRE, this problem was fixed. You can try 1.4.2_04,
_05 or 1.5 beta2 etc.

*** This bug has been marked as a duplicate of 188454 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
I have tested with JDK 1.4.2_04 and this problem has not been fixed in this 
build. There is no 1.4.2_05 available at Sun's site.

I downloaded and installed JDK 1.5.0-beta but Mozilla fails to start with 
error:
[root@RedHat9 mozilla-1.6]# ./mozilla
INTERNAL ERROR on Browser End: Could not get the plugin manager
System error?:: Success

Product: Core → Core Graveyard
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.