Overflow properties doesn't work with object which are XUL documents

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
P2
normal
RESOLVED WORKSFORME
14 years ago
4 years ago

People

(Reporter: Xanthor Sccas, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040411 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040411 Firefox/0.8.0+

When we embed a XUL document in a XHTML one, with the object tag, and when we
try to specify differents values for the overflow property, it doesn't work.

Reproducible: Always
Steps to Reproduce:
1. Load the URL
2. Compare the first objects with XUL files and the last one with HTML file
Actual Results:  
At first seen, it's like if all XUL objects where with overflow : hidden
But sometimes, when you swith to another tab or another window and come back,
the text of the XUL file is shown even outside the object. 

Expected Results:  
Scrollbars for the auto and scroll properties

I think that this is a regression, because with Mozilla 1.6 and Firebird 0.7 the
scrollbars existed.

(I don't know if I should put this bug in XP toolkit : XUL)
The fact that 'overflow' on the OBJECT or IFRAME is applied to the HTML document
is really a quirk. 'overflow' on the OBJECT element controls what happens if the
child elements of the OBJECT overflow, but the OBJECT doesn't really have
children. It's just "the document". You really need to control this using
'overflow' *inside* the XUL document.
hmm. I take it back. I don't know what's going on here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Well, per CSS overflow applied to a replaced element means nothing, last I
checked....
Keywords: qawanted
No, it applies to replaced elements.
http://www.w3.org/TR/CSS21/visufx.html#propdef-overflow

I think this testcase should work as Xanthor expects. I'm actually not sure how
the XUL content escapes from the box in the first place...

Updated

14 years ago
Depends on: 230863
OS: Linux → All
Hardware: PC → All

Comment 5

11 years ago
Testcase?
QA Contact: ian → layout.view-rendering
Assignee: roc → nobody
Is this still an issue ?
Flags: needinfo?(roc)
The testcase has gone away.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(roc)
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.