Incorrectly displays the list as double-spaced.

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: berryr, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

The page was designed using Frontpage. Using IE the list displays as
single-spaced, and the page lays out accordingly. Using Mozilla, the list shows
as double-spaced.

Reproducible: Always
Steps to Reproduce:
1.Go to the above URL with Mozilla.
2.Go to the above URL with IE
3.Compare

Actual Results:  
The list in IE is single-spaced; the list in Mozilla is double-spaced.

Expected Results:  
Already stated.

I was using the Sky Pilot theme. I haven't yet tested with other themes.
The markup in question looks like:

<td>
  <span>
    <p>Text</p>
  </span>
</td>

By default, Mozilla puts a 1em margin on <p> tags.  We have a quirk for compat
with NS4 and IE -- when a <p> is the first (respectively last) child in a <td>,
we remove the top (respectively bottom) margin.

In this case, the <p> is not a child of <td> at all, so the margins stay where
they are.

If the page author doesn't want the margins, they can be removed in the page's
stylesheet.  Similarly, making the document sorta valid (by not putting <p>
inside <span>) would resolve the issue.

I think we've considered introducing quirkier behavior (more like IE's) here and
decided against it, since what we have now solves the common cases.

Comment 2

14 years ago
Comment 1 seems to say that the bug is invalid, so resolving it.

The URL is a 404 now or I would have made this a TE bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.