We need up-to-date artwork for the icons of loading-images and broken-images

RESOLVED FIXED in mozilla1.9

Status

()

Core
Layout: Images
--
trivial
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: amano, Assigned: faaborg)

Tracking

({polish})

Trunk
mozilla1.9
polish
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -
wanted-next +
wanted1.9 -
blocking1.8.1 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments, 7 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040122 Firefox/0.8.0+ (MNG,DOMi,Venkman)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040122 Firefox/0.8.0+ (MNG,DOMi,Venkman)

When displaying folders and files with the gopher or ftp protocol, only 2 color
icons are displayed.

Reproducible: Always
Steps to Reproduce:
1. Browse to an FTP or Gopher site.
2.
3.

Actual Results:  
You see the very plain artwork (only about 2 colours).

Expected Results:  
Render folder and file icons in a high resolution and with at least 256 colours.
Maybe system specific standard folder/file icons should be used.

Updated

14 years ago
Assignee: firefox → arvid
QA Contact: mconnor
(Reporter)

Comment 1

14 years ago
Created attachment 146161 [details]
Compare the ftp site mentioned above with this IE pic!
(Reporter)

Comment 2

14 years ago
Technically some files in \Firefox\res\html\ should be replaced. Exspecially
gopher-menu.gif and gopher-unknown.gif (they are all called gopher*.* but are
used for displaying FTP folders and files as well).

We have to question ourselves if the current division into gopher-binary,
gopher-audio,... is still the way to go. They could all be replaced by a new
better looking gopher-unknown.gif for files in general and gopher-menu.gif for
folders.

So I tinkered a bit with the folder-item.png of the firebird base skin (Qute by
Arvid Axelsson) and created 2 new gif files to replace the former mentioned ones.
I made them float a bit (with a transparent line on the bottom), because
formerly there was a glitch with the link line being visible for one pixel on
the left of the gif files.
(Reporter)

Comment 3

14 years ago
Created attachment 146460 [details]
Proposed new gif file for folders

To replace gopher-menu.gif in the firefox\res\html\ subfolder.
(Reporter)

Comment 4

14 years ago
Created attachment 146461 [details]
Proposed new gif file for files

Proposed gif files to replace gopher-unknown.gif (and maybe gopher-audio.gif,
gopher-binary.gif, gopher-find.gif, gopher-image.gif, gopher-movie.gif,
gopher-sound.gif and gopher-telnet.gif as well) in the firefox\res\html\
subfolder.
(Reporter)

Comment 5

14 years ago
Created attachment 146463 [details]
Pic of firebird with manually exchanged .gif files

I made a pic of the ftp site. Before I manually replaced the .gif files in my
current firebird install with the ones I proposed. 

IMO the result is much more pleasing than the former one.
(Reporter)

Comment 6

14 years ago
Sorry for spamming this thread again. 

I was browsing gopherspace and ftp sites for 2 hours now and the decision
suggested in comment #2 seems to have been made already. I could not find ONE
single file extension (.txt,...) that was hooked up with the mentioned files
(gopher-audio.gif,gopher-binary.gif, gopher-find.gif, gopher-image.gif,
gopher-movie.gif,gopher-sound.gif and gopher-telnet.gif). So either I was
unlucky or these files are not used anymore.

On a sidenote. The README file in my screenshot looks a bit seperated in my
screenshot above. This is intentional and not the result of the exchanged
artwork. Both my .gif files are 19x19 pixels.

Arvid, as the owner of this bug, what do you think of the idea of replacing the
.gif files with some of your Qute artwork?
(Reporter)

Comment 7

14 years ago
Correction:

The location for these artwork files in CVS is NOT \res\html\
but is \layout\html\base\src . The former location is the subfolder if installed
on your harddisk.

Updated

14 years ago
Blocks: 194220

Comment 8

14 years ago
can the file type for those two icons be changed to image/gif instead of
application/octet-stream?

http://bugzilla.mozilla.org/attachment.cgi?id=146460&action=edit
http://bugzilla.mozilla.org/attachment.cgi?id=146461&action=edit
(Reporter)

Updated

14 years ago
Attachment #146460 - Attachment mime type: application/octet-stream → image/gif
(Reporter)

Updated

14 years ago
Attachment #146461 - Attachment mime type: application/octet-stream → image/gif
(Reporter)

Updated

14 years ago
Attachment #146460 - Flags: review?(arvid)
Comment on attachment 146460 [details]
Proposed new gif file for folders

arvid is no longer the default theme maintainer for Firefox.
Attachment #146460 - Flags: review?(arvid)
kevin, this is actually pretty darn ugly.  Any chance of cleaning this stuff up
pre-1.0?
Assignee: arvid → webmail

Comment 11

14 years ago
It would be great to get some updated artwork in here. These are in /layout so
changing these would also affect Seamonkey, correct? Mike, is there a chance
that we can replace the images when Firefox builds? Or better yet replace them
with PNGs if possible...

While we're at it we might as well update the loading and broken images icons.

CCing Stephen
Status: NEW → ASSIGNED
(Reporter)

Comment 12

14 years ago
Well, if you don't want to change this for Seamonkey as well, just land the
updated artwork on the aviary branch. 

Good to see some movement here now ;) Why not just use the images from the
current firefox default skin for bookmark folders/files?

And please let the artwork "float" over the link line (as shown in my example
http://bugzilla.mozilla.org/attachment.cgi?id=146463&action=view by adding some
transparent lines on the bottom) because currently some pixels of the link line
are shown on the left side of the gif (which doesn't look so bad if the gif
floats above the line.

TNX for picking this up.
why not replace the "New for 1996!" icons for seamonkey too? :)  If you come up
with a patch, I can help drive r+sr for changes in layout.  Its not like the
current icons are integrated with classic/modern or anything.

Comment 14

14 years ago
Well I wouldn't want to impose Winstripe or Pinstripe on Seamonkey :) I think
what we'll have to do is come up with a neutral icon set that can be used across
platforms/products.

We can either go that route or try to match the style of each theme. Matching
the theme would be ideal for consistency.
(Reporter)

Comment 15

14 years ago
I don't have any problem with changing this for Seamonkey as well. ;)

Tweaked summary to include Kevin's proposal to fix the broken and loading images
icons as well.
Changed "Firefox" to "Browser", and added a Firefox 1.0 target to the Status
Whiteboard.

Since Kevin is the bug owner I will leave all decisions to him. I am already
keen on seeing the new artwork.
Component: General → Layout: Images
Product: Firefox → Browser
Summary: FTP/Gopher icons for folders and files should use up-to-date artwork → Up-to-date artwork for these icons: FTP/Gopher folders and files and loading and broken images
Whiteboard: Firefox 1.0 targeted
Version: unspecified → Trunk
lets go with the neutral solution for now, then figure out a way to make this
stuff skinnable.  I don't think it is now, so it'd be better to have a neutral
look that works with all themes.

Comment 17

14 years ago
The icons are garish and don't fit *stripe at all, so requesting some love
before 1.0...

This is the Firefox version of bug 165319 (image placeholder icons are ugly). 
In it I suggested replacing the default with a PNG version of the same and then
overloading the PNG during the Firefox build process (say, by adding the new
images and creating toolkit/layout/Makefile.in or the like with code roughly
replicating lines ~158-165 at link below).  I never got a response about whether
it was feasible or not, but I have little doubt it is (as long as Firefox is
built after Gecko, that is).  Then you could replace the images with whatever
you want.

In a week or so I'll have a computer where building Firefox requires less than
three hours, so I'll see what I can hack up by way of code to hook up icons
separate from layout.  Note that fewer than no guarantees that I'll get anywhere
exist, even though I think converting the images to PNG is very easily doable.

http://lxr.mozilla.org/aviarybranch/source/layout/html/base/src/Makefile.in#158
Flags: blocking-aviary1.0?
Can we change these files to PNGs or are we stuck with GIFs for now?
Not a blocker.

Stephen, I see no reason why they'd have to be GIFs.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 20

14 years ago
Created attachment 159762 [details]
Zip of patch with images to place in same dir as originals

This zip contains a diff that'll change the names to PNG throughout aviary.  It
also contains the images converted to PNGs.  I'm currently running Firefox with
the patch applied, and everything seems to work for me.

Comment 21

14 years ago
Comment on attachment 159762 [details]
Zip of patch with images to place in same dir as originals

Vlad, can you either review this or pass it on to someone who can?  The patch
changes the references to the broken and loading images, which are the ones
most likely to be seen in Firefox, to PNG equivalents.	The PNGs should be as
small as possible, as I ran them through PNGCrush with the -reduce and -rem
alla options (reduce color depth and remove all text chunks except for
transparency).

Ideally these images would only be placeholders until they can be overridden
for Firefox.  For now, this patch should have no visible effect because the PNG
images are the exact same as the GIFs.	As far as I know, all apps ship with
the png decoder, so it wouldn't be an extra dependency anywhere.

This patch is for aviary only; it should change *every* reference in aviary
(including the ones in Thunderbird code).  Creating a trunk patch should be
quite similar, but I haven't made one because trunk is a secondary concern
right now.
Attachment #159762 - Flags: review?(vladimir)
I am close to finishing up the new icons for this. Are we just going to change
it Mozilla wide, or is it possible to make it theme specific before 1.0? Is it
going to be a problem when Firefox theme changes start escaping toolkit and
browser into layout?
(Reporter)

Comment 23

14 years ago
If I understand Jeff correctly, any changes/updates to the png images on teh
branch (AFTER the patch being checked in) will affect Firefox 1.0 and Firefox
0.9/1.0. 

If this patch would be checked in on the trunk any updates/changes to the png
images would affect Firefox and Thunderbird, while changing/updating the
correspondent .gif images would only affect Seamonkey then.

Am I right?

Stephen, now with the png updates only affecting the standalone apps (in the
near future), I would vote that the theme changes should go with the Fx default
theme.

Any other suggestions?

Comment 24

14 years ago
(In reply to comment #23)
> If I understand Jeff correctly, any changes/updates to the png images on teh
> branch (AFTER the patch being checked in) will affect Firefox 1.0 and Firefox
> 0.9/1.0. 
> 
> If this patch would be checked in on the trunk any updates/changes to the png
> images would affect Firefox and Thunderbird, while changing/updating the
> correspondent .gif images would only affect Seamonkey then.

Checking it into the branch would affect Firefox 1.0.  If it were checked into
trunk, it would affect Seamonkey as well (by making Seamonkey, or more correctly
the layout engine, use PNG versions of the two images).  The important thing to
note is that my patch only converts the images into PNG format -- it doesn't
change the images used.  That would be for some Firefox build-config master to
do with to-be-provided images.

This patch would only affect Firefox because it's aviary-only.  If it were for
trunk, it would affect Firefox, Seamonkey, and any other app that currently uses
the images -- but only by changing the format of the current images.  I hope
that's clear enough.
Created attachment 160123 [details]
New "modern" icons for loading and broken

I have new icons for loading and broken images. Still working on the Gopher/FTP
icons. Does anyone know if Firefox even uses icons besides the folder and
generic file icon?

Aside from that, checking these kind of changes in is outside of what I am
allowed to do. So if someone with authority wants to change the references to
png, and check in the images let me know and I will post the 16x16 pngs.
Created attachment 160690 [details]
FTP/Gopher updated icons

Updated FTP/Gopher icons. I can't actually find where any of the others are
used, but I figured I would update them anyway. Made them less Winstripe
specific and more neutral since they are Mozilla wide (for now anyway).
(Reporter)

Comment 27

14 years ago
Sweet. They look very professional.

Now let't hope that Vlad can review the patch fast, so that we can polish Fx in
time for 1.0
(Reporter)

Comment 28

14 years ago
@Kevin/Stephen:
At the current state, we don't know if the patch gets reviewed and approved in
time for the 1.0 release. Maybe a better way to ensure that these new goodies
would be to convert them to gif and replace with them the existing .gifs on the
branch. 

If the patch gets reviewed and approved in time, the .pngs could be checked in
as well then.

And, please, consider my suggestion in comment #12 to let the FTP file and
folder icons hover over the link line a bit (because that looks much better than
having them "sit" there with the 2pixels of link line to the left of the icon as
it is currently).
(Reporter)

Comment 29

14 years ago
Created attachment 161227 [details]
New icons split into separate gifs

I played around and split Stephen's png file into separate gifs. I will attach
a pic that shows the new icons in action.
(Reporter)

Updated

14 years ago
Attachment #146161 - Attachment is obsolete: true
Attachment #146460 - Attachment is obsolete: true
Attachment #146461 - Attachment is obsolete: true
Attachment #146463 - Attachment is obsolete: true
(Reporter)

Comment 30

14 years ago
Created attachment 161228 [details]
Stephen's new icons in action (Screenshot)
(Reporter)

Comment 31

14 years ago
The patch doesn't seem to get reviewed in time for 1.0. I would vote to check in
gopher-unknown.gif, gopher-menu.gif, broken-image.gif and loading-image.gif only
to keep the buildsize as small as possible (and because we don't know if the
other images are hooked up at all).
(Reporter)

Comment 32

14 years ago
I filed Bug 269017 to address the issue that the existing artwork in /res/html
isn't hooked up with the proper filetypes.
(Reporter)

Comment 33

14 years ago
Vlad, are you still planning to review this patch? Or did it fall off your radar?

Comment 34

14 years ago
Comment on attachment 159762 [details]
Zip of patch with images to place in same dir as originals

Patch very, very likely no longer applies.  I'll make another one soon...
Attachment #159762 - Attachment is obsolete: true
Attachment #159762 - Flags: review?(vladimir)
(Reporter)

Comment 35

14 years ago
Jeff, would it be possible to add gopher-menu.gif and gopher-unknown.gif to the
patch as well? (to fix the FTP look. the other gopher-XXX files are confirmed to
not being hooked up). 

Maybe Mike Connor can review, since he offered his help.

Comment 36

14 years ago
(In reply to comment #35)
> Jeff, would it be possible to add gopher-menu.gif and gopher-unknown.gif to the
> patch as well? (to fix the FTP look. the other gopher-XXX files are confirmed to
> not being hooked up). 
> 
> Maybe Mike Connor can review, since he offered his help.

Possibly.  I have other patches which need review and matter more to me right
now, tho, so I'm not going to make a new version and then ask for a review quite
yet.
(Reporter)

Comment 37

14 years ago
@Kevin:
Since there is no working patch for png support available, could you check in
your updated  icons in the .gif format maybe?

I know that this would result in a slightly greater build size, but this could
be compensated eg. by removing some of the unused gopher files.
(Reporter)

Comment 38

13 years ago
*Bump*

Since no patch appeared to let us check these great icons as pngs, why don't we
simply convert them to gifs to fix this as a bandaid for Firefox 1.1?

Kevin?

Comment 39

13 years ago
Created attachment 191044 [details]
All the new icons as GIF.

Here are all the new icons as GIF, unzip them in /res to use them. The
placeholders for broaking/loading images probably need an official update,
because these are derived from the print screen.

It should be easy enough to replace all these old icons for FF1.1.
(Reporter)

Comment 40

13 years ago
Thanks for converting the jpeg files to gifs. I attached a new attachment with
only 4 of your gif files in it.

The reason is that those are the only ones that are currently hooked up in Gecko
engine (confirmed already by Christian Biesinger/Boris Zbarsky in bug #269017).
Since the updated icons are bigger, we shouldn't check those in until they are
actually used to not increase the build size of Firefox without any actual user
benefit.

Mike Connor, since you wanted these icons in comment #10 for Firefox 1.0, do you
want them for 1.5?

The 4 gif files in my ZIP attachment would be ready for a checkin.
(Reporter)

Comment 41

13 years ago
Created attachment 192050 [details]
Only those gif files that are actually used
Attachment #161227 - Attachment is obsolete: true
Attachment #161228 - Attachment is obsolete: true

Updated

12 years ago
Flags: blocking1.8.1?
Too late to block on this bug, especially with the long lack of activity here.
Flags: blocking1.8.1? → blocking1.8.1-
Note that if your patches are languishing, that's a problem.  Please try and contact appropriate module owners to get them reviewed.  However, please don't use the release-blocker process to try to get them in unless they really are release blockers.
(Reporter)

Comment 44

12 years ago
Well. The ancient look of the ftp icons made it to the news of a german tech magazine: http://www.winfuture.de/news,29828.html  Obviously Netscape is advertising a refined look for its browser and compares it to our 2 colour icons: http://screenshots.winfuture.de/1170666186.jpg
(Reporter)

Updated

12 years ago
Whiteboard: Firefox 1.0 targeted

Updated

12 years ago
Keywords: polish

Comment 45

12 years ago
bug 269017 is now about using a stylesheet for the index/directory output, so one can more easily change the look&feel (like for the new Netscape edition?)
Depends on: 269017

Comment 46

11 years ago
Given that bug 294800 has now been checked in, I think the summary should be changed to remove reference to FTP (unless further changes are planned, that is).

Comment 47

11 years ago
Also, I am confused as to why the files are in GIF format instead of PNG?
(Reporter)

Comment 48

11 years ago
Tweaked the title as per AndrewM's suggestion. Firefox 3 Alpha 8 now displays ftp and gopher listings very fine now.
Summary: Up-to-date artwork for these icons: FTP/Gopher folders and files and loading and broken images → We need up-to-date artwork for the icons of loading-images and broken-images
Whiteboard: [wanted-firefox3]

Comment 49

11 years ago
Marking as fixed by bug 294800.
(and the one icon left in /res/html is folder.png, which has also undergone restyling by the same bug 294800).
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 50

11 years ago
No, this actually isn't fixed by that -- note the summary, try this link on trunk:

data:text/html,<img%20src="http://fbsds.com/dfisoa.jpg">
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: wanted1.9+
Whiteboard: [wanted-firefox3]
Flags: wanted1.9-
Flags: wanted1.9+
Flags: wanted-next+
(Assignee)

Comment 51

10 years ago
Does anyone know if this is a Firefox icon, I see it in place of broken-image.png sometimes:

https://bugzilla.mozilla.org/attachment.cgi?id=317462
(Assignee)

Comment 52

10 years ago
Created attachment 317469 [details]
loading-image.gif for Firefox 3

Since these icons are not going to be themeable for this release (bug 420811), beltzner and I worked with the iconfactory to produce new simplified images that can be used on all platforms.  These images are intentionally devoid of any particular style so they won't look out of place when appearing on a very wide variety of different web pages.  This can be landed in place of the current (late 90s era) loading-image.gif
(Assignee)

Comment 53

10 years ago
Created attachment 317470 [details]
broken-image.gif for Firefox 3

This image can replace the current broken-image.gif
(Assignee)

Updated

10 years ago
Assignee: kevin → reed
Status: REOPENED → NEW
Keywords: checkin-needed
QA Contact: mconnor → layout.images
Assignee: reed → faaborg
Comment on attachment 317469 [details]
loading-image.gif for Firefox 3

a1.9=beltzner
Attachment #317469 - Flags: ui-review+
Attachment #317469 - Flags: approval1.9+
Comment on attachment 317470 [details]
broken-image.gif for Firefox 3

a1.9=beltzner
Attachment #317470 - Flags: ui-review+
Attachment #317470 - Flags: approval1.9+
Checking in layout/generic/broken-image.gif;
/cvsroot/mozilla/layout/generic/broken-image.gif,v  <--  broken-image.gif
new revision: 1.4; previous revision: 1.3
done
Checking in layout/generic/loading-image.gif;
/cvsroot/mozilla/layout/generic/loading-image.gif,v  <--  loading-image.gif
new revision: 1.4; previous revision: 1.3
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9
(Assignee)

Comment 57

10 years ago
>Does anyone know if this is a Firefox icon, I see it in place of
>broken-image.png sometimes

Never mind, answer showed up in bug 430613
Target Milestone: mozilla1.9 → ---
Target Milestone: --- → mozilla1.9

Comment 58

10 years ago
faded icons, may add more colors?

Comment 59

10 years ago
Could the stock icons image-loading and image-missing be used on Linux? It would make things integrate nicely.
(Assignee)

Comment 60

10 years ago
We can't theme the icons for specific platforms (bug 420811)

Updated

10 years ago
Duplicate of this bug: 165319
You need to log in before you can comment on or make changes to this bug.