Closed Bug 240634 Opened 21 years ago Closed 20 years ago

Silent install requires user input for installation path

Categories

(Firefox :: Installer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 229706

People

(Reporter: moz, Assigned: bugs)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

When installing Firefox silently using the -ms or -ma command line switches I 
am being shown the Install Folder dialog box. I believe that using these 
options should just install Firefox to the default location, either showing the 
dialog boxes (but not asking for user input) in the case of -ms or not showing 
anything on the screen in the case of -ma.

By altering the config.ini file by changing a number of the 'Show Dialog=TRUE' 
settings to 'Show Dialog=FALSE' I can force the installer to get further, but 
it always seems to leave at least one dialog open (i.e. removing one makes 
another appear, removing too many stops the installer from working).



Reproducible: Always
Steps to Reproduce:
1. Clean Windows XP machine
2. Latest copy of Firefox installer (FireFoxSetup.exe 15-Apr-2004 11:58)
3. Open a command prompt, and try to run it using 'FireFoxsetup -ms'


Actual Results:  
Dialog box asking for Installation Folder

Expected Results:  
No Dialog box - the software should just automatically install

*** This bug has been marked as a duplicate of 229706 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.