double right or middle click in tab bar creates new tab

RESOLVED DUPLICATE of bug 244692

Status

()

--
trivial
RESOLVED DUPLICATE of bug 244692
15 years ago
13 years ago

People

(Reporter: ce.ceo, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

if you double middle click or double right click in an empty area in the tab bar
it creates a new tab

Reproducible: Always
Steps to Reproduce:
1. double right or middle click in tab bar
2.
3.

Actual Results:  
new tab created

Expected Results:  
no new tab created
the event listener for ondblclick doesn't differentiate between
right/left/middle clicks, and I really don't see the need.  If you double-click
on something with your right mouse button.
Severity: normal → trivial
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

15 years ago
I found this buy by rapidly middle-clicking tabs to close them, and all of a sudden a new one was 
created. This is a bug! Is it really that hard to check if both presses are from the left button? By 
definition, a double click is the left button, unless otherwise specified. When you say click, it means left 
button. Should doulbe click be different? If you are not going to fix this bug, and wrongfully mark it as 
resolved without fixing it, then you will need to update the documentation to replace all instences of 
"double click" with "press any combination of 2 mouse buttons one after the other" or replace all 
instences of click with "left click". Ether way, things have to be consistent.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 217560 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

15 years ago
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 244692 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.