Closed Bug 240678 Opened 17 years ago Closed 17 years ago

Mozilla 1.7b (and Firefox 0.8) is busy waiting on synchronous xmlhttprequest

Categories

(Core :: XML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 190313

People

(Reporter: lhofhansl, Assigned: hjtoi-bugzilla)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316

When using synchronous xmlhttprequest, both Mozilla 1.7b on Linux, and Firefox
0.8 on Windows 2000 use 100% CPU time while waiting for the server.

If xmlhttprequest is used asynchronously (using the onload callback) no extra
CPU time is used.


Reproducible: Always
Steps to Reproduce:
This is the code used:

   var httpReq = new XMLHttpRequest();
   httpReq.open("POST", "<server URL>", false, null, null);
   httpReq.setRequestHeader("Content-Type","application/x-www-form-urlencoded");
   httpReq.send( "something" );

Actual Results:  
Mozilla uses 100% CPU while waiting for the server.

Expected Results:  
Waiting should use no CPU time.

*** This bug has been marked as a duplicate of 190313 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.