error messages blocking whole mozilla window (all tabs) --> annoying

RESOLVED DUPLICATE of bug 123913

Status

enhancement
RESOLVED DUPLICATE of bug 123913
15 years ago
11 years ago

People

(Reporter: grosser.meister.morti, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

When an error occurs (e.g. site not found) a error window pops up which blocks
the whole mozilla window, not only the tab in which the error occured. It would
be MUCH nicer if the error will be shown only in the tab, where the error really
occured.

I think this would be best solved by displaying a layer over the current page
(of the error-tab) in which the error message is displayed. A OK button should
be also placed on this layer. So the error message would not longer be a
seperated (popup) window, it would be embedded in the tab (in which the error
occured).

I think this would be a great idea for all popup dialoges (e.g. for the
http-authentification dialoge).

Reproducible: Always
Steps to Reproduce:
1. A popup message (like a error message) pops up.

Actual Results:  
The mozilla window is blocked.

Expected Results:  
Embed a (error) messsage into the specific tab.

*** This bug has been marked as a duplicate of 123913 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Reporter

Comment 2

15 years ago
Damn. I really thought, that I searched well enough! But apperently I didn't,
cause I still can't find that existing bug report!
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.