Ability to "migrate" a profile from one computer to another

RESOLVED DUPLICATE of bug 22689

Status

enhancement
RESOLVED DUPLICATE of bug 22689
15 years ago
3 years ago

People

(Reporter: garnold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207

Add the ability to migrate a profile from an old computer to a new computer, and
make it easy enough that anyone can do it.  Perhaps something as easy as a menu
item or button in the Profile Manager that says "Migrate this profile to another
computer", then pack up all the profile's files into one file (zip?).  Then, on
the "receiving" computer, an option to "Bring in a profile from another
comupter" that will read the migration file, unpack the files inside it, and fix
any absolute paths so everything just works.  This would be especially handy for
folks who keep their email in local folders.

I could have really used this feature today, helping an old lady get her new
computer all set up -- paths were wrong, settings were goofed, and when manually
making changes, I kept forgetting to escape the backslashes.  There has to be a
better way!

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
This is already covered by bug 187564 and bug 22689. Marking as a dupe of the
latter.

*** This bug has been marked as a duplicate of 22689 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.