Build failure on nsFileSpec.cpp

VERIFIED FIXED

Status

()

Core
XPCOM
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: David G King, Assigned: dougt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Building on Win XP SP2(beta) using MinGW and Cygwin (gcc 3.3.1) I get the
following error :-

make[3]: Entering directory `/cygdrive/c/mozilla/source/mozilla/xpcom/obsolete'
nsFileSpec.cpp
Building deps for nsFileSpec.cpp
/cygdrive/c/mozilla/source/mozilla/build/cygwin-wrapper g++ -march=athlon-xp -mm
mx -msse -mno-cygwin -o nsFileSpec.o -c -DOSTYPE=\"WINNT5.1\" -DOSARCH=\"WINNT\"
 -D_IMPL_NS_COM_OBSOLETE -I.. -I/cygdrive/c/mozilla/source/mozilla/xpcom/obsolet
e/../io  -I../../dist/include/xpcom -I../../dist/include/string -I../../dist/inc
lude/libreg -I../../dist/include/xpcom_obsolete -I../../dist/include -I../../dis
t/include/nspr          -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-a
rith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-v
irtual-dtor -Wno-long-long -pedantic -mms-bitfields -pipe  -DDEBUG -D_DEBUG -DDE
BUG_Kings -DTRACING -g   -DX_DISPLAY_MISSING=1 -DMOZILLA_VERSION=\"1.8a\" -DHAVE
_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREA
DS=1 -DWINVER=0x400 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=
1 -DD_INO=d_ino -DSTDC_HEADERS=1 -Duid_t=int -Dgid_t=int -DHAVE_DIRENT_H=1 -DHAV
E_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_LIBM=1
 -DNO_X11=1 -DMMAP_MISSES_WRITES=1 -DHAVE_STRERROR=1 -DHAVE_SNPRINTF=1 -DHAVE_ME
MMOVE=1 -DHAVE_RINT=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DMOZ_DEFAULT_TOOLKIT=\
"windows\" -DMOZ_APP_NAME=\"mozilla\" -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -D
MOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DMOZ_MATHML=1 -DMOZ_LOGGING=1 -DDETECT_WEBSHEL
L_LEAKS=1 -DHAVE___CXA_DEMANGLE=1 -DMOZ_DEMANGLE_SYMBOLS=1 -DMOZ_USER_DIR=\"Mozi
lla\" -DMOZ_XUL=1 -DMOZ_PROFILESHARING=1 -DMOZ_PROFILELOCKING=1 -DMOZ_DLL_SUFFIX
=\".dll\" -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1 -DMOZ_REFLOW_PE
RF=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZILLA_LOCALE_VERSION=\"1.8a\" -DMOZILLA_REGION_
VERSION=\"1.8a\" -DMOZILLA_SKIN_VERSION=\"1.5\"  -D_MOZILLA_CONFIG_H_ -DMOZILLA_
CLIENT /cygdrive/c/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.cpp
In file included from ../../dist/include/string/nsString.h:74,
                 from c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.h:148,

                 from c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.cpp:38
:
../../dist/include/string/nsTString.h:446: error: function `void
   nsString::AppendInt(unsigned int, int)' definition is marked dllimport.
In file included from ../../dist/include/string/nsString.h:79,
                 from c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.h:148,

                 from c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.cpp:38
:
../../dist/include/string/nsTString.h:446: error: function `void
   nsCString::AppendInt(unsigned int, int)' definition is marked dllimport.
In file included from c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.cpp:50
3:
c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.h: In constructor `
   nsDirectoryIterator::nsDirectoryIterator(const nsFileSpec&, int)':
c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.h:742: warning: `
   nsDirectoryIterator::mDir' will be initialized after
c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.h:731: warning:   `
   nsFileSpec nsDirectoryIterator::mStarting'
c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.h:731: warning: `
   nsDirectoryIterator::mStarting' will be initialized after
c:/mozilla/source/mozilla/xpcom/obsolete/nsFileSpec.h:727: warning:   `PRBool
   nsDirectoryIterator::mExists'
make[3]: *** [nsFileSpec.o] Error 1
make[3]: Leaving directory `/cygdrive/c/mozilla/source/mozilla/xpcom/obsolete'
make[2]: *** [libs] Error 2
make[2]: Leaving directory `/cygdrive/c/mozilla/source/mozilla'
make[1]: *** [alldep] Error 2
make[1]: Leaving directory `/cygdrive/c/mozilla/source/mozilla'
make: *** [alldep] Error 2


I tried all sorts of tricks to fix this, as well as a search in Bugzilla, but to
no avail.
cls has a patch for this I believe...

Comment 2

14 years ago
See bug 240106.
(Reporter)

Comment 3

14 years ago
I searched for a dup bug yesterday (NZST), so missed the patch cls posted after
my search. Oh well, such is life with international development.

Marking this a dup.

*** This bug has been marked as a duplicate of 240106 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
I'm having the same problem since 04/14 using cygwin and following mingw packages:

binutils-2.15.90-20040222-1.tar.gz
gcc-core-3.3.3-20040217-1.tar.gz
gcc-g++-3.3.3-20040217-1.tar.gz
mingw-runtime-3.2.tar.gz/mingw-runtime-3.3.tar.gz
w32api-2.5.tar.gz

The patch for Bug 240106 did not fix it.

This are the last lines of my build log:

nsFileSpec.cpp
Building deps for nsFileSpec.cpp
/cygdrive/c/Mozilla/mozilla/build/cygwin-wrapper g++ -mno-cygwin -o nsFileSpec.o
-c -DOSTYPE=\"WINNT5.1\" -DOSARCH=\"WINNT\" -D_IMPL_NS_COM_OBSOLETE -I..
-I/cygdrive/c/Mozilla/mozilla/xpcom/obsolete/../io  -I../../dist/include/xpcom
-I../../dist/include/string -I../../dist/include/libreg
-I../../dist/include/xpcom_obsolete -I../../dist/include
-I../../dist/include/nspr          -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -pedantic -mms-bitfields -pipe  -DDEBUG
-D_DEBUG -DDEBUG_Matthias_Bockelkamp -DTRACING -g -O   -DX_DISPLAY_MISSING=1
-DMOZILLA_VERSION=\"1.8a\" -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1
-DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DWINVER=0x400 -DSTDC_HEADERS=1
-DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino -DSTDC_HEADERS=1
-Duid_t=int -Dgid_t=int -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1
-DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_LIBM=1 -DNO_X11=1
-DMMAP_MISSES_WRITES=1 -DHAVE_STRERROR=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1
-DHAVE_RINT=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1
-DMOZ_DEFAULT_TOOLKIT=\"windows\" -DMOZ_APP_NAME=\"mozilla\" -DOJI=1 -DIBMBIDI=1
-DMOZ_VIEW_SOURCE=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DMOZ_LOGGING=1
-DDETECT_WEBSHELL_LEAKS=1 -DHAVE___CXA_DEMANGLE=1 -DMOZ_DEMANGLE_SYMBOLS=1
-DMOZ_USER_DIR=\"Mozilla\" -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1
-DMOZ_DLL_SUFFIX=\".dll\" -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1
-DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZILLA_LOCALE_VERSION=\"1.8a\"
-DMOZILLA_REGION_VERSION=\"1.8a\" -DMOZILLA_SKIN_VERSION=\"1.5\" 
-D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT
/cygdrive/c/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.cpp
In file included from ../../dist/include/string/nsString.h:74,
                 from c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.h:148,
                 from c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.cpp:38:
../../dist/include/string/nsTString.h:446: error: function `void 
   nsString::AppendInt(unsigned int, int)' definition is marked dllimport.
In file included from ../../dist/include/string/nsString.h:79,
                 from c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.h:148,
                 from c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.cpp:38:
../../dist/include/string/nsTString.h:446: error: function `void 
   nsCString::AppendInt(unsigned int, int)' definition is marked dllimport.
In file included from c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.cpp:503:
c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.h: In constructor `
   nsDirectoryIterator::nsDirectoryIterator(const nsFileSpec&, int)':
c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.h:742: warning: `
   nsDirectoryIterator::mDir' will be initialized after
c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.h:731: warning:   `nsFileSpec 
   nsDirectoryIterator::mStarting'
c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpecWin.cpp:720: warning:   when 
   initialized here
c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.h:731: warning: `
   nsDirectoryIterator::mStarting' will be initialized after
c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpec.h:727: warning:   `PRBool 
   nsDirectoryIterator::mExists'
c:/Mozilla/mozilla/xpcom/obsolete/nsFileSpecWin.cpp:720: warning:   when 
   initialized here
{standard input}: Assembler messages:
{standard input}:2375: Warning: Ignoring changed section attributes for .text
make[3]: *** [nsFileSpec.o] Error 1
make[3]: Leaving directory `/cygdrive/c/Mozilla/mozilla/xpcom/obsolete'
make[2]: *** [tier_2] Error 2
make[2]: Leaving directory `/cygdrive/c/Mozilla/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/cygdrive/c/Mozilla/mozilla'
make: *** [build] Error 2
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

14 years ago
What source tree are you using?  What does 'cvs -z3 stat
xpcom/string/public/nsTString.h' return?

Comment 6

14 years ago
I'm using the mozilla-source.tar.bz2 file with daily updates via "make -f
client.mk checkout". 

I cannot try the "cvs -z3 stat xpcom/string/public/nsTString.h" command at this
time, because my server at home runs the scheduled build process, and I can only
access it on weekends. But from the checkout log I see that the last update to
that file happened on 04/16. 

Comment 7

14 years ago
The fix was checked in on 4/19 so it looks like your tree isn't being updated
properly.  Try adding MOZ_CO_FLAGS=-PA to your script so that any sticky flags
are properly removed per http://www.mozilla.org/cvs.html#sandbox .


Comment 8

14 years ago
(In reply to comment #5)
> What source tree are you using?  What does 'cvs -z3 stat
> xpcom/string/public/nsTString.h' return?

C:\Mozilla\mozilla>cvs -z3 stat xpcom/string/public/nsTString.h
===================================================================
File: nsTString.h       Status: Up-to-date

   Working revision:    1.13
   Repository revision: 1.13    /cvsroot/mozilla/xpcom/string/public/nsTString.h,v
   Sticky Tag:          (none)
   Sticky Date:         (none)
   Sticky Options:      (none)

I'll try the -PA option tonight.

Comment 9

14 years ago
Finally it works. I was using a tool called "redir.exe" to create a build log
including stderr output. That caused the problem.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 10

14 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.