If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Get error message and image doesn't download

VERIFIED DUPLICATE of bug 123662

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 123662
14 years ago
14 years ago

People

(Reporter: Tim, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Get an alert: "The file /en/mercedesbenz/graphics/videoteaser.jpg cannot be
found. Please check the location and try again."

It is as if the start of the URL is lost. If you add a question mark at the end
of the URL the image loads OK. E.g.
http://www.atptennis.com/en/mercedesbenz/graphics/videoteaser.jpg?

Reproducible: Always
Steps to Reproduce:
1. Copy URL into address area
2. Press enter


Actual Results:  
Get an alert: "The file /en/mercedesbenz/graphics/videoteaser.jpg cannot be
found. Please check the location and try again."


Expected Results:  
Load the image at the specified URL.

Comment 1

14 years ago
WFM Mozilla trunk build 2004041809 WinNT4

Comment 2

14 years ago
WFM with a Linux Gtk2 build from today.

Comment 3

14 years ago
WFM : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040416
Firefox/0.8.0+

Reporter, pls re-open if this issue appears for your when you update to a more
recent build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 4

14 years ago
Maybe the reporter should try clearing his cache?

I had errors like these pop up sometimes for files that were b0rked in Mozilla's
cache, but clearing the cache fixed that. Of course, if you change the URL ever
so slightly, a new copy will be downloaded which would explain why adding the
questionmark helps.

Of course, what's evil about this message is that it makes you assume the file
can't be found on the server, not that there's some problem in the cache...

np: Vladislav Delay - Kainuu (Demo(n) Tracks)
arg, this bug is really a duplicate, worksforme is totally the wrong resolution
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

*** This bug has been marked as a duplicate of 123662 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE

Comment 7

14 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
Summary: Get error message and image doesn't download. → Get error message and image doesn't download
You need to log in before you can comment on or make changes to this bug.