Middle mouse button/Scroll wheel functionality

VERIFIED FIXED in 0.7

Status

--
enhancement
VERIFIED FIXED
15 years ago
11 years ago

People

(Reporter: ethan.custodio, Unassigned)

Tracking

unspecified

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Adding functionality to the middle mouse button/scroll wheel would increase
productivity. For example, if the cursor was over the main calendar, scrolling
the mouse wheel up or down would change the current time/day/week or even
month/year (depending on the view)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Reasonable enhancement request. Changing status to NEW, hardware and OS to ALL
Hit return too early last time. :(
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All

Comment 3

14 years ago
I think that's a terrible idea.  The scroll wheel is meant for scrolling
something that has a scroll bar.  It would be much better to fix the Month view
so that scrolling really works.  (It already does in the other main views.)

Comment 4

14 years ago
FYI, I'm using 2005011113-cal for Thunderbird 1.0.2 ona debian unstable system.

Updated

13 years ago
QA Contact: gurganbl → general

Comment 5

13 years ago
*** Bug 317713 has been marked as a duplicate of this bug. ***
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

Comment 7

11 years ago
Fixed by checkin for bug 375389.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7

Comment 8

11 years ago
Verified in lightning (build 2007080603) and sunbird (build 20070806) -> task is fixed.
Status: RESOLVED → VERIFIED

Comment 9

11 years ago
This is an HORRENDOUS feature.

My PC is reasonably quick, (3Ghz/750Mb of RAM etc.) but scrolling the calander in week view takes about 4 seconds, during which time it just hangs. This is with just one local calander.

This means if I nudge the wheel accidently, and click somewhere without realising, it interprets it as clicking on another event.

The other problem is that you have no idea whether the program is currently working and is about to scroll up or down by one week, perhaps more, so you can over compensate. You are left trying to second guess what the program is going to do next, waiting until you are sure it is idle. 

It reminds me of the early 90s when you had to remember what was in the keyboard buffer, and predict what the program would do next.

Also the scroll wheel is sometimes interpreted as initially moving in the opposite direction than it is supposed to, meaning you don't even know which direction its about to move. CHAOS! It almost makes the program unusable.

Comment 10

11 years ago
Sorry- I should have said, that last paragraph is a physical hardware problem, I mean the wheel is highly sensitive, but its normally not a noticable effect because its instantaneous in other programs.
I don't see a reason to remove this functionality. The reason you are getting such high load times is that you probably have a bunch of remote calendars. They are currently not being cached, or only partially. This will change with offline support, where calendars are going to be cached. Reads from this cache are much faster.

Also, in general please use new bugs. The bugs for offline support are already filed though.
You need to log in before you can comment on or make changes to this bug.