Closed Bug 241106 Opened 18 years ago Closed 17 years ago

Bug : No Keyboard input with XSLT

Categories

(Core :: XSLT, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 236596

People

(Reporter: leo.daniele, Assigned: peterv)

Details

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.6) Gecko/20040113

I have reduced my code to the minimum to try to find the problem :
When I create INPUT fields via xsl , the keyboard input do not work in an 
intermittent way !


Reproducible: Always
Steps to Reproduce:
1.launch enonce.xml
2.click into the first input field
3.tape on the keyboard

Actual Results:  
the text is not displayed :
If I swap to another task (and return to mozilla), the keyboard input come 
back.... if I swap has new to another task (and return to mozilla): the 
keyboard input do not work ... AND SO ON



------------------------------------------
my (enonce.xml) file (reduced to the minimum)
------------------------------------------
<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet type="text/xsl" href="enonce.xsl"?>
<test>
</test>

------------------------------------------
my (enonce.xsl) file (reduced to the minimum)
------------------------------------------
<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0" 
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:output method="html"/>
 <xsl:template match="/">
 <HTML>
  <HEAD> 
  </HEAD>  
     <BODY >
<input name="question1" size="50"/><br/>
<input name="question2" size="50"/><br/>
<input name="question3" size="50"/><br/>
<input name="question4" size="50"/>
      </BODY>
 </HTML>
 </xsl:template>
</xsl:stylesheet>
Whiteboard: DUPEME
I think this bug is a dupe of bug 236596 (maybe to that bug should be added to
the summary: no keyboard input)
Depends on: 236596
Hi there,
is anybody going to fix this bug? We (Software AG) have developed a product
which converts mainframe 3270 terminal screens into XML on the fly, and
presents them in a browser using XSLT. Simlified sample attached. Works with
IE. Works with Mozilla once, but when you submit the form, it reloads itself,
and then the input field is blocked. If you press TAB then shift+TAB, then you
can type. In real life, it doesn't reload itself, of course, but loads the next
screen.
Our customers are keen to use our software with Mozilla rather than IE, but
this bug is a showstopper for it!
Steffen

*** This bug has been marked as a duplicate of 236596 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.