[patch] Accel + up/down arrown should act as top/bottom.

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
Accessibility
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Jasper, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino0.9
PowerPC
Mac OS X

Details

Attachments

(1 attachment, 1 obsolete attachment)

810 bytes, patch
Mike Pinkerton (not reading bugmail)
: review+
Simon Fraser
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
Most native OS X application go to the top or the bottom of the page when
accel+up/down arrows are used (Xcode, TextEdit, Safari).

For laptop users this is must to easily go to the top or he bottom of webpages.
(Reporter)

Comment 1

14 years ago
Created attachment 146633 [details] [diff] [review]
patch to do this

This patch edits the platformHTMLBInding.xml file so that Camino and Mozilla on
OSX will allow the use of accel+up/down to go to the top or bootom of the page.
(Reporter)

Updated

14 years ago
Summary: Accel + up/down arrown should act as top/bottom. → [patch] Accel + up/down arrown should act as top/bottom.
(Reporter)

Updated

14 years ago
Attachment #146633 - Flags: review?

Comment 2

14 years ago
Note that PowerBook users already have this functionality using fn+up/down.
(Reporter)

Comment 3

14 years ago
I know, but it would be good if we have the same behaviour as other native
applications. Or not?
(Assignee)

Updated

14 years ago
Target Milestone: --- → Camino0.9
(Assignee)

Updated

13 years ago
Blocks: 261393
(Assignee)

Comment 4

13 years ago
Created attachment 159965 [details] [diff] [review]
fix typo in patch
Attachment #146633 - Attachment is obsolete: true
(Assignee)

Comment 5

13 years ago
Comment on attachment 159965 [details] [diff] [review]
fix typo in patch

r=pink

smfr, can you sr this really quick? it's in mozilla.
Attachment #159965 - Flags: superreview?(sfraser)
Attachment #159965 - Flags: review+

Updated

13 years ago
Attachment #159965 - Flags: superreview?(sfraser) → superreview+
(Assignee)

Comment 6

13 years ago
Comment on attachment 159965 [details] [diff] [review]
fix typo in patch

landed on trunk, need approval to land on moz 1.7 branch
Attachment #159965 - Flags: approval1.7.x?

Comment 7

13 years ago
Comment on attachment 159965 [details] [diff] [review]
fix typo in patch

a=asa for checkin to the 1.7 branch
Attachment #159965 - Flags: approval1.7.x? → approval1.7.x+
(Assignee)

Comment 8

13 years ago
landed on trunk and 1.7branch. 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

13 years ago
*** Bug 186698 has been marked as a duplicate of this bug. ***
Comment on attachment 146633 [details] [diff] [review]
patch to do this

clearing review? flag from obsoleted patch on a fixed bug :-)
Attachment #146633 - Flags: review?
You need to log in before you can comment on or make changes to this bug.