If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sanity Check bitches about valid email addresses

RESOLVED DUPLICATE of bug 127862

Status

()

Bugzilla
Administration
RESOLVED DUPLICATE of bug 127862
14 years ago
5 years ago

People

(Reporter: John Delaney, Assigned: justdave)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; .NET CLR 1.1.4322)
Build Identifier: 2.17.7

The code in Sanity Check to look for bad email addresses returns all rows even 
the ones with good email addresses. It then complains about the good addresses, 
as well as the bad ones.

I have verified the select that Sanity Check uses manually in our installation 
of 4.0.18-nt. The select as built by Sanity Check returns all rows, not just 
the bad ones, as it is seemingly programmed to do.

Reproducible: Always
Steps to Reproduce:
1.run Sanity Check
2.
3.

Actual Results:  
It complains about valid email addresses

Expected Results:  
It should not complain about the valid addresses

I have got Bugzilla working quite happily on nt. It does not seem able to send 
mail. I have extracted the code snippet from BugMail.pm and verified that the 
changes specified in 2.4.1.3.2 of the 2.17.7 manual are correct. I can send 
mail from a perl programme using that snippet. The problem in Sanity Check is 
the only error I can find. I am concerned that if Sanity Check can get it 
wrong, other cgi programmes might be doing so as well.
It's possible that regexps are broken in the NT version of MySQL.

We very recently changed this in cvs to do the regexps in Perl instead of in the
SQL, mostly because all of the other places the emailregexp is used, it's done
in Perl, and MySQL's regexp parsing isn't quite the same as Perl's.

Can you cvs update, or apply the patch from bug 127862, and see if that fixes it?
(Reporter)

Comment 2

14 years ago
I pinched the code out of checksetup.pl and applied it to sanity check. Sanity 
check now works satisfactorily on email addresses. It looks like, as Dave said, 
you can't always trust your database supplier.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
just for accurate record-keeping then...
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
... since there was no code checked in as a result of this bug.

*** This bug has been marked as a duplicate of 127862 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.