Select next message when deleting message slow; causes selection jump backward

NEW
Unassigned

Status

SeaMonkey
MailNews: Message Display
--
minor
14 years ago
2 years ago

People

(Reporter: Dan Mellem, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

I use Mozilla mail for IMAP, without the preview pane, and I mark the messages
for deletion. When I get a batch of new mail, I go through and delete all of the
junk messages using the arrow and DEL keys. After I delete a message and scroll
down several messages to the next message to be deleted, the selection bar jumps
back to the message following the one I deleted. Mozilla shouldn't select a
message if the focus has changed from the current message. This would also be
resolved if Mozilla stayed on the current message instead of automatically
advancing to the next.

Reproducible: Always
Steps to Reproduce:
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 1

13 years ago
Dan:
"I've tried it in Mozilla 1.8b2 (builds 20050308 and 20050702) and SeaMonkey
1.1a (build 2005091706) and all still show the same problem. I wasn't able
to try it in the latest build of SeaMonkey (2005091806) since it won't run.

The best way to test this is to have, say, five messages in a row. Delete
number 4, up-arrow 3x, and then hit delete again to delete number 1.
Instead, it will drop below #4, go back up to it, and undelete it (or
perhaps #3). You can also test it going down. If you start on #2 and hit
[delete][down][delete] quickly it will delete #2 and #3. If you go slightly
slower (about 1/2 second pause), it will delete #2 and #4."

Comment 2

9 years ago
still see this in current SM trunk?
(Reporter)

Comment 3

9 years ago
It's not as noticeable since it's faster, but yes, it still happens if you're going quickly. I sent "test1" through "test9" to my e-mail account. I deleted test1, hit the down arrow 4x, then tried to delete test5, but it usually deletes test4 (sometimes it'll delete test3 or test5 depending on timing).
You need to log in before you can comment on or make changes to this bug.