Closed Bug 241259 Opened 16 years ago Closed 16 years ago

Add a CSS tag for "Additional Comments"

Categories

(Bugzilla :: Creating/Changing Bugs, defect, trivial)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: altlist, Assigned: altlist)

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040210 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040210 Firefox/0.8

Could we add a CSS tag to the "Additional Comments" line?  It's helpful to
highlight this line to help break up the comments.  

Reproducible: Always
Steps to Reproduce:
Attached patch suggested patch (obsolete) — Splinter Review
Here's my suggested patch.  Then add this line in edit_bug.css

   .bz_comment { background-color: #e0e0e0; }
Comment on attachment 146723 [details] [diff] [review]
suggested patch

Please use quotes in order to be both HTML and XHTML valid. If you have only
letters, <span class="something"> or <span class=something> are both valid in
HTML, but only the first is valid in XHTML as well.

Secondly (and more importantly), your identation level for the start tag is not
the same as the identation level of the ending tag, which detones the tag been
used in different logical levels. That's a bug. As far as I can tell, you close
the span tag even if count == 0, but you open it only when count > 0. Starting
and closing it should be done at the same logical level.

Looks good otherwise.
Attachment #146723 - Flags: review-
Comment on attachment 146723 [details] [diff] [review]
suggested patch

to aid the next reviewer, please use diff -u15 or whatever it takes to result
in the patch only having one hunk. thanks :)
Attached patch updated patch (obsolete) — Splinter Review
Thanks for pointing out the bug.  Updated patch enclosed (using -u15!).
I set the span to only enclose the text, but not the private/work_time
comments. 

Also includes the patch to edit_bug.css.
Attachment #146723 - Attachment is obsolete: true
I know this is a nit, but the templates are readable because we nit-pick.....

When you add the <span> and </span> surrounding a section of template code, the
code in between needs to be indented 2 more spaces so that the hierarchy is clear.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 146726 [details] [diff] [review]
updated patch

Per joel's comments.
Attachment #146726 - Flags: review-
Attached patch updated patchSplinter Review
Per Joel's comment, cleanly indented the new block
Attachment #146726 - Attachment is obsolete: true
Comment on attachment 147076 [details] [diff] [review]
updated patch

r=vladd
Attachment #147076 - Flags: review+
Flags: approval?
Target Milestone: --- → Bugzilla 2.18
-> patch author

a= justdave
Assignee: myk → altlst
Flags: approval? → approval+
FIXED. Thanks Albert!

Checking in template/en/default/bug/comments.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/comments.html.tmpl,v
 <--  comments.html.tmpl
new revision: 1.11; previous revision: 1.10
done
Checking in css/edit_bug.css;
/cvsroot/mozilla/webtools/bugzilla/css/edit_bug.css,v  <--  edit_bug.css
new revision: 1.7; previous revision: 1.6
done
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Summary: add a css tag to "Additional Comments" → Add a CSS tag for "Additional Comments"
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.