Default Theme is "crapped out" when installing new Mozilla w/ Netscape 7.1 installed as well.

RESOLVED DUPLICATE of bug 107694

Status

SeaMonkey
Themes
--
major
RESOLVED DUPLICATE of bug 107694
14 years ago
10 years ago

People

(Reporter: Brock Lynn, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

I have Windows XP Home. I also have Netscape 7.1 already installed. I wanted to
see how well Mozilla is, so I downloaded and installed 1.6. I ran it... I't
literally looked like SH*T. The theme was totally snafu'd out the a$$. God... it
looked so aweful I immediately uninstalled it... See the print icon was really
messed up... it looked like a split in half original "stop" icon, the "red green
and yellow traffic light deal"... the back, forward, reload, and stop
icons/buttons were all screwed up something terrible. And it generally looked
horrible. Dude...

So I figured something was messed up with 1.6. I purged it, and downloaded 1.7
Beta. Same sh*t... God... this is horrible... I thought to myself... Maybe I
better stick with Netscape 7.1 from AOL. But then I figured... hmm... maybe
something's wrong with the default theme, and so I went to the settings and set
the theme to be the "modern" theme. That solved it all.

Then I figured, maybe the developers haven't noticed this deal, because when
they install, it's not a "clean" install, since the "theme settings" from the
previous installs are still in the Windows XP registry, which bypass the screwed
up default theme that comes up when you do a fresh install. So I figgered I
should post a bug report... otherwise more people will try the thing, puke in
disgust, purge it from the system, and never try it again.

Dude, it just don't look cool... see...?? ;)

So just fix the default theme.

Thanks.


Reproducible: Always
Steps to Reproduce:
1. Start with a freshly installed Windows XP Home system.
2. Install Netscape 7.1 from AOL.
3. Then install Mozilla.
4. Mozilla looks really disgustingly f*cked up.
5. Go to settings and change theme to "modern" and it fixes it.

Actual Results:  
Just after a fresh new install of Mozilla on a computer that has never had
Mozilla ever installed on it before, but which does have Netscape 7.1 from
AOL... The theme that automatically displays is screwed to hell and back...
enough so to make someone never want to ever run Mozilla again. I'm serious...
it looks brain damaged that way.

Expected Results:  
The initial window of Mozilla Navigator should look "decent" and nice when first
starting after a fresh clean brand new install for the first time ever. It
should look nice so that the "customer" would want to continue to use it.

I said it was a "Major" problem, since if you don't have users, because you have
chased them all away, from a Hideously Medusa-looking first install... then
what's the point in having the program at all. ;)
> 2. Install Netscape 7.1 from AOL.
> 3. Then install Mozilla.

The Mozilla release notes clearly say NOT to use the same profile as you use
with Netscape.  See http://mozilla.org/releases/mozilla1.7b/known-issues.html#prefs 

We can't help the fact that Netscape 7.1 hijacks the "Mozilla" directory to
install its prefs into....

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 107694 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.