Last Comment Bug 241367 - Spurious line break in first ordered list line to contain a link/anchor.
: Spurious line break in first ordered list line to contain a link/anchor.
Status: RESOLVED DUPLICATE of bug 167467
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: general
:
:
Mentors:
http://www.rotted.com/fs8/race/doc/in...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-22 13:32 PDT by Kris Feldmann
Modified: 2005-03-20 09:37 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Kris Feldmann 2004-04-22 13:32:39 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

In the first ordered list on the page,
http://www.rotted.com/fs8/race/doc/install.html#1, notice that Mozilla inserts a
line break between the unlinked and linked text. I've experimented and found
that it adds the spurious line break always right before the first link in the
ordered list, be it in the first item or further down. Subsequent items in the
list behave as expected as you can see.

Reproducible: Always
Steps to Reproduce:
1. Create an ordered list.
2. In two of the list items, include a hyperlinked word.

Actual Results:  
The first occurance of a linked word will have an unintended line break just
before the link.

Expected Results:  
Only break lines between list items or other block delimitters.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2004-04-22 15:44:41 PDT
The markup is:

<a name="whatever">
<ul>
  <li> Text <a href="something"> More text </a> </li>
</ul>

Now this is not valid HTML, since an <a> element may not contain another <a>
element (and may not contain <ul> either).  So the parser fixes it up to:

<ul>
  <a name="whatever">
    <li> Text </li>
  </a>
  <a href="something"> More text </a>
</ul>

See where the linebreak is coming from?

This is already filed...
Comment 2 Aaron McBride 2004-04-25 20:39:15 PDT
this also occurs with the xhtml format: <a name="whatever" />
Comment 3 Dave Gross 2004-08-20 12:10:55 PDT
This also resets the font size (and probably other things) at the point of the
line break.  See, for instance:
     http://www.sniggle.net/Experiment/index.php?entry=19Aug04
Comment 4 Dave Gross 2004-08-20 12:16:52 PDT
And note that the page:
http://www.sniggle.net/Experiment/index.php?entry=19Aug04
Is valid xhtml, without &lt;a&rt; elements embedded in other &lt;a&rt; elements.
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-03-19 20:18:05 PST

*** This bug has been marked as a duplicate of 167467 ***
Comment 6 Dave Gross 2005-03-20 09:37:29 PST
You've marked this bug as a duplicate of a bug marked "RESOLVED INVALID" - but
this bug is NOT resolved nor is it invalid (it still exists in current versions
of Mozilla/Firefox, and it happens even when displaying a page that uses valid
XHTML/CSS).  I recommend either reopening this bug, or reopening Bug 167467.

Note You need to log in before you can comment on or make changes to this bug.