Without flash installed some pages don't seem to finish loading

RESOLVED DUPLICATE of bug 241592

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 241592
14 years ago
14 years ago

People

(Reporter: zug_treno, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

Without Macromedia Flash installed http://www.anandtech.com never seems to
finish loading, although all other content is seemingly there.

Most pages with Flash exhibit the same problem, but sometimes this can be
corrected by going back/forward to/from another page.


Reproducible: Always
Steps to Reproduce:
1. Go to http://www.anandtech.com (or another page with Flash).
2. Watch the status bar.
Actual Results:  
The status bar says something like 'Transferring data from
dynamic.anandtech.com...' or 'Read images.anandtech.com', the progress bar is
still visible and the mouse cursor stays in the progress state (arrow +
hourglass). Even after an hour's wait the browser will not time out, but the
Stop-button will work. 

Expected Results:  
Like in earlier Mozilla builds: display 'done' in the status bar, progress bar
not shown anymore and the mouse cursor changed back to the normal arrow. All
without showing the Flash ads.

Changing theme, profile or HTTP pipelining did not solve the problem, installing
the latest Flash plug-in did.

Comment 1

14 years ago
WFM: build 20040416, please retest with a newwer build.
(Reporter)

Comment 2

14 years ago
After testing (a lot of) earlier versions: Gecko/20040411 has this problem,
Gecko/20040410 does not. Plug-in bug 216218 was fixed around that time, could
that be related?

Updated

14 years ago
Blocks: 241592

Comment 3

14 years ago
In the very similar (or perhaps identical) bug 241592, the problem has been
narrowed to a combination of a flash object and an image without an explicit
size. See that bug for a simplified testcase. I can't say for certain whether
that combination also applies to anandtech.com's site. (anandtech.com does
contain unsized images, but giving them sizes in a local copy of the file didn't
seem to help. However, I could have goofed. It's a big, messy site.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dupe of bug 241592. Duping this against that bug instead of the other way around
since the other bug has a testcase.

*** This bug has been marked as a duplicate of 241592 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.