Directory and files gets create when starting Mozilla with a profile that point to a invalid directory

VERIFIED DUPLICATE of bug 62418

Status

Core Graveyard
Profile: BackEnd
P3
enhancement
VERIFIED DUPLICATE of bug 62418
19 years ago
2 years ago

People

(Reporter: Henrik Gemal, Assigned: Conrad Carlen (not reading bugmail))

Tracking

({helpwanted})

Trunk
mozilla0.8
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
To reproduce:
- Delete all your profiles
- Create a new profile called "test" in the C:\temp\test directory.
- Exit Mozilla
- Delete the C:\temp\test directory
- Start Mozilla

Mozilla is started and the C:\temp\test directory is created!!!!

Expected:
Mozilla is started and a alert is shown that the current profile is invalid and
then the Profile Manager is shown.

Using build:
2000011608

Updated

19 years ago
Assignee: selmer → racham

Comment 1

19 years ago
Bhuvan, was the described behavior the one we decided on?  It may be useful to
show the dialog before continuing (but I wouldn't hold beta for that.)

Updated

19 years ago
Target Milestone: M15

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
The described behavior is the one we decided on i.e., recreating the directory
that user has lost. That directory will bw filled with the default profile
files. Let us consider alert as an enhancement. Marking TFV as M15.

Updated

19 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 3

19 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.

Comment 4

19 years ago
Marking enhancement.  It would still be good to get into beta2 if possible.
Severity: normal → enhancement

Updated

19 years ago
Target Milestone: M15 → M16

Updated

19 years ago
Target Milestone: M16 → M17

Comment 5

19 years ago
Moving this to M30 and adding help wanted keyword.
Assignee: racham → nobody
Status: ASSIGNED → NEW
Keywords: helpwanted
Target Milestone: M17 → M30
(Reporter)

Comment 6

18 years ago
Created attachment 12308 [details]
Screenshot of dialog when Netscape 4.x doesn't find profile directory
(Reporter)

Comment 7

18 years ago
Putterman: shouldn't it be pretty easy to add a check to the profile back end 
wheather the profile directory actually exist?
If it doesn't then just throw the Profile Selection dialog.
Assignee: nobody → putterman
OS: Windows 98 → All
Hardware: PC → All

Comment 8

18 years ago
Reassingin to myself..
Assignee: putterman → racham

Comment 9

18 years ago
Doing a mass reassign to Conrad Carlen.

Conrad is going address all current and upcoming profile manager issues. Please
do not hesitate to involve me in any of the issues.
Assignee: racham → ccarlen
(Assignee)

Comment 10

18 years ago
We need to have UI on the front end for this. When a profile dir is not found,
it should allow the user to do something about it. A little work needs to be
done on the back end as well. Currently nsProfile::GetProfileDir does a bunch of
things which it should not. It creates the dir if it doesn't exist and makes it
the current profile (?!?!). This needs to be broken apart. It should simply
return the dir and if it does not exist, the front end could use this info and
put up UI like 4.x did. 
Status: NEW → ASSIGNED
(Assignee)

Comment 11

18 years ago
Setting milestone to M0.08
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 12

18 years ago
Sorry, that milestone should have been mozilla0.8
(Assignee)

Comment 13

18 years ago
Marking as dup of bug 62418. There is a patch posted on that bug.

*** This bug has been marked as a duplicate of 62418 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 14

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.