focus information not saved when in history

VERIFIED DUPLICATE of bug 36539

Status

()

enhancement
VERIFIED DUPLICATE of bug 36539
15 years ago
11 years ago

People

(Reporter: manish.jethani, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040418

As you navigate through links on a page using the TAB key, the next link gets
selected each time. Similarly, it is possible to navigate through the frames
using F6. Now when you follow a link and come back, the focus does not get
restored to the previously selected link and frame. The focus information ("last
focused") is not saved in the history (wheres the FORM data and scroll position is).

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.google.com/ and search for "web browsers"
2. Keep hitting the TAB key until the link for "Netscape" (netsape.com) gets
selected.
3. Hit ENTER to visit Netscape's website.
4. Come "Back" to the Google search results page.
Actual Results:  
The focus is not set to the Netscape link. Hitting TAB again starts the
navigation from the top of the page.

Expected Results:  
The focus should be set to the Netscape link, since it is the "last selected
control" on that page.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.