Some forms of malformed absolute URL don't work like the browsers of the majority of the people.

VERIFIED DUPLICATE of bug 19917

Status

()

Core
Networking
P3
minor
VERIFIED DUPLICATE of bug 19917
19 years ago
19 years ago

People

(Reporter: fearl, Assigned: Judson Valeski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When we checked out M12 under Linux against our WWW site, we discovered what
could be a problem with Mozilla's operation.  Our site (as of 11:00a CST,
1-17-00) had a minor variance from the spec in our HTML content that current and
past versions of the popular browsers support- we're correcting it on the site
so you will need to rig a test site to verify.  This variance was in the
formatting of an absolute URL; it was of the format
"//www.passkey.net/foo/bar.gif".  The browser does not correctly load the images
or anything else for that matter.  Using Netscape 4.5, IE 4.X or later, or the
latest version of Opera on various platforms, the site renders as we intended.

Could it be set up to make an assumption about the URL when it's formatted like
this (such as assuming that the malformed URL is using the server protocol of
the page just fetched...)?

Updated

19 years ago
Assignee: troy → gagan
Component: Layout → Networking
QA Contact: petersen → tever

Comment 1

19 years ago
Changing component and re-assigning to network folks

Updated

19 years ago
Assignee: gagan → valeski
Target Milestone: M14

Comment 2

19 years ago
Jud: Assigning this one to you. I'm not sure whether this is a webshell thing,
makeabsolute, or a url parsing problem.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
The site renders fine with my new urlparser stuff, for now marking as dup of bug
19917

*** This bug has been marked as a duplicate of 19917 ***

Comment 4

19 years ago
verified dup of bug 19917 4.xP Partial URLs of the form //hostname/path resolved 
wrongly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.