Fails to generate multiple pages when printing and previewing

RESOLVED DUPLICATE of bug 154892

Status

()

Core
Printing: Output
--
major
RESOLVED DUPLICATE of bug 154892
14 years ago
14 years ago

People

(Reporter: Paul, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040425

When trying to print or print-previewing www.tweakers.net (which is displayed
perfectly correct during normal browsing) it fails to generate multiple pages
for the page and tries to put in on a single page. This doesn't work offcourse
and the pages gets truncated at the and of the paper (actually printed to test
on my Brother HL820).

I tested it on my P4 desktop an Centrino laptop on both using IE6 and mozilla,
IE6 does it correct and prints multiple pages, mozilla doesn't.

Reproducible: Always
Steps to Reproduce:
1. Open http://www.tweakers.net
2. Click "File>Print Preview" to see the bad Preview render
3. Print to see it actually print the bad page it just displayed

Actual Results:  
It tries to put everything on one page and truncates everything on the border of
the paper (thus outside the margins).

Expected Results:  
obvious: use multiple pages and chop the web-site in pieces

I think it's due to the nature of page, being completly JS generated multiple
layer complicated CSS.

I actually found some more bugs during which i'll maybe take a closer look at
(hint: try printing (not print previewing) the page while one of the
'Frontpage', 'Nieuws', 'Aankondingen', 'meuktracker' or even other drop-down
menu is still dropped down (which shouldn't be possibily dropped down during
printing in the first place...) it will display a large white squar in the
middle of the page as a background for the drop-down menu)
(Reporter)

Comment 1

14 years ago
Created attachment 147019 [details]
incorrect print previewing: failed to generate multiple pages

I made a screen shot of it.
The page is in Landscape instead of portrait, but that doesn't matter since
it's displayed and printed wrong anyway.

*** This bug has been marked as a duplicate of 154892 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.