bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

bookmarks sidebar creates empty contextmenu when no items are selected

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
P5
trivial
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Sekundes, Assigned: Kyle Yuan)

Tracking

({fixed-aviary1.0})

unspecified
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040422 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040422 Firefox/0.8.0+

     

Reproducible: Always
Steps to Reproduce:
1.Ctrl + B.
2.the caret should be focus on the search textbox rather than the items of
bookmarks.
3.right click on the empty area of the bookmarks tree view.
Actual Results:  
empty contextmenu is created.

Comment 1

14 years ago
I'm pretty sure that at some point I've seen something like this been reported
before, but I can't find anything to dupe it against! Maybe I'm wrong and I'm
thinking of something else. mconnor will probably know.

But this bug is certainly real.
Component: General → Menus
OS: Windows 2000 → All
QA Contact: bugzilla
Hardware: PC → All
not where I can test this, this is more like a bookmarks bug though.

empty as in blank?  what does Bookmarks Manager do with nothing selected?  
maybe we need that behaviour implemented?

Comment 3

14 years ago
Yeah, empty as in it creates a tiny contextmenu with nothing inside it. Note
that to reproduce this you need to open the bookmarks sidebar and focus on the
search caret and make sure that nothing else is selected in the sidebar.

Then right click on some empty whitespace below the bookmarks, and you'll see
this. Your bookmarks list has to be sufficiently short that it doesn't take up
the entire screen so you get some whitespace.

--> minor
--> Bookmarks
Assignee: firefox → p_ch
Severity: normal → minor
Component: Menus → Bookmarks
QA Contact: bugzilla → mconnor

Updated

14 years ago
Severity: minor → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Confirmed.

The focus is on the search textbox when I open the bookmarks sidebar CTRL+B, but
I get that empty context menu when clicking on the whitespace below the bookmarks.

- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040522
Firefox/0.8.0+
- Microsoft Windows 2000 Pro 5.00.2195 SP4
(Reporter)

Updated

14 years ago
Flags: blocking1.0?

Comment 5

14 years ago
Should be simple to fix, and it's a little bit sloppy in a finished product. If
we can get to it, great, otherwise it's the first thing cut ;)
Flags: blocking1.0? → blocking1.0+
Priority: -- → P5
(Assignee)

Comment 6

14 years ago
Created attachment 153389 [details] [diff] [review]
do not popup context menu when selection is undefined
Assignee: p_ch → kyle.yuan
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #153389 - Flags: review?(firefox)

Comment 7

14 years ago
blake, ben, can one of you review this short patch? 
Comment on attachment 153389 [details] [diff] [review]
do not popup context menu when selection is undefined

>   createContextMenu: function (aEvent, aSelection)
>   {
>+    if (aSelection == undefined) {
>+      aEvent.preventDefault();
>+      return;
>+	}
>+

fix the tab here, and the spacing for the closing bracket, and r=me.
Attachment #153389 - Flags: review?(firefox)
Attachment #153389 - Flags: review+
Attachment #153389 - Flags: approval-aviary?
(Assignee)

Comment 9

14 years ago
Comment on attachment 153389 [details] [diff] [review]
do not popup context menu when selection is undefined

fixed in trunk. waiting approval for aviary branch.

Comment 10

14 years ago
Comment on attachment 153389 [details] [diff] [review]
do not popup context menu when selection is undefined

a=asa for branch checkin.
Attachment #153389 - Flags: approval-aviary? → approval-aviary+
(Assignee)

Comment 11

14 years ago
fixed in aviary branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
*** Bug 259148 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.