List bullet image shown twice after selecting text from a list item

RESOLVED DUPLICATE of bug 235390

Status

()

Core
Layout
--
trivial
RESOLVED DUPLICATE of bug 235390
14 years ago
13 years ago

People

(Reporter: Jasper, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

If you select text from a second level list item on the What's New page (it was
the same with at least a few earlier versions) the bullet image is shown twice
(one in the correct location before the text and one after it through the text,
I am going to attach a screenshot). I have tried to replicate the bug with a
simpler page, but somehow I couldn't.
Oh, and please note that this bug only happens with nested lists, not with the
top-level lists.

Reproducible: Always
Steps to Reproduce:
1. Go to the What's New page
(http://www.mozilla.org/releases/mozilla1.7rc1/README.html).
2. Select text from a second level list item (in the Chatzilla section for
example). Double-clicking also works (but it also selects text, so I think
selecting the text is what triggers the bug).

Actual Results:  
After performing the steps above the list bullet image got duplicated, a few
millimeters to the right of the original.

Expected Results:  
Mozilla should have left the list bullet image alone.
(Reporter)

Comment 1

14 years ago
Created attachment 147122 [details]
A screenshot of the problem.
(Reporter)

Comment 2

14 years ago
Some other notes: The extra bullet image stays visible until it is scrolled off
the screen and back again, scrolling it while keeping the problem line on the
screen doesn't remove it.

Comment 3

14 years ago
Created attachment 147126 [details]
testcase (all in one file)

This reduced testcase is pretty small and someone understanding css well should
quickly find out what's the problem.
This (like the original page) "works" in IE and Opera, but it's still possible
they just cannot do something that Mozilla can and that causes the visible
problem.

To test, just select open the testcase (having internet connection, it's
loading a gif from mozilla.org) and select the word "family".

Comment 4

14 years ago
Additional info for testcase:
- You can also reduce the ".3em", but I think that's all.
- Setting the font size to other values than 88-90% will not trigger the bug
here, so maybe you might not see the bug on other systems with different fonts...
- Setting padding-left to 0em or 2em will also not trigger the bug, only 1em.

I know opinions when a bug should be set to "new" differ and this might well be
a bug in the web page (I'd call the construction of the bullets adventurous at
least), not Mozilla layout or style system, but at least this has a testcase to
quickly decide what's the problem, so confirming to get some experienced eyes on
this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 5

14 years ago
I heard it's not reproduceable on Linux.

Comment 6

14 years ago
dupe of bug 237766?
(Reporter)

Comment 7

14 years ago
It might be related, but it's under different circumstances, bug 237766 is
related to hovering over a list item (which is a link), while this bug appears
when selecting something. Also, bug 237766 is apparently unrelated to the level
of the list item, while this bug seems to only appear on nested lists.
Depends on: 237766

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 235390 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
No longer depends on: 237766
You need to log in before you can comment on or make changes to this bug.