Opening resp. downloading unknown mime content-type should also give an "open with mozilla" option, especially for text/*

RESOLVED DUPLICATE of bug 57342

Status

Core Graveyard
File Handling
--
enhancement
RESOLVED DUPLICATE of bug 57342
14 years ago
2 years ago

People

(Reporter: Martin von Gagern, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040319
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040319

Today I twice had the situation that I wanted to just view some plain text file
while browsing. One was at the location given, of type text/xebuild, the other a
C++ file on my disc described as text/c++-program or something like that. Both
times mozilla gave me the options to either open them with my default editor,
choose an application or just save them. I wouls very much like to have a fourth
option "Display text in browser window" that simply treats the data as plain
text. It is to argue if this option should be always present or just for text/*
content type. I vote for always, and leave the decision up to the user.

Reproducible: Always
Steps to Reproduce:
1. Selected Link to text/* unknown mime type

Actual Results:  
Options:
1. open using <some text editor>
2. open using <choose application> Browse
3. save to disk

Expected Results:  
4. display as text in browser window

*** This bug has been marked as a duplicate of 57342 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.