Cannot open any document in href "file://" URL

RESOLVED DUPLICATE of bug 84128

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 84128
13 years ago
13 years ago

People

(Reporter: Adriano Labate, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If I have a <a> tag with a href
"file://jules/Production/0Documentspouroffres/Magglingen020708.pdf", clicking on
the link does not open the PDF file document. I also tried "file://///" as
generated by Macromedia but it fails too. 
Firefox simply does nothing. It can be a DOC, PDF, or a folder. It's also
impossible to "open link in new tab".

Jules is a network server that is accessible locally. All works well with
Internet Explorer. The page is served by the HTTP server of Tomcat 5.

Thanks

Reproducible: Always
Steps to Reproduce:
1. click on the link
2. 
3.

Actual Results:  
nothing

Expected Results:  
open the related document, for example a PDF file, or open Word with the DOC file.

I am developing the corporate intranet site. And we have some pages with lots of
simple links on documents (DOC, PDF, XLS, etc). It works with IE but not with
Firefox.

Comment 1

13 years ago
see the release notes how to disable this security feature
http://www.mozilla.org/releases/mozilla1.7rc1/known-issues.html#psm

IMO a duplicate of bug 84128.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.