Fix sherlock plug-ins

RESOLVED FIXED in Firefox1.0beta

Status

()

Firefox
Search
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.0beta
fixed-aviary1.0
Points:
---
Bug Flags:
blocking0.9 -
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(9 attachments, 2 obsolete attachments)

Mustn't forget to add our ebay sherlock file item.
Status: NEW → ASSIGNED
Flags: blocking0.9+
Priority: -- → P3
Target Milestone: --- → Firefox0.9
Not blocking 0.9. 
Flags: blocking1.0+
Flags: blocking0.9-
Flags: blocking0.9+
Target Milestone: Firefox0.9 → Firefox1.0beta
Well, we have one netscape wrote way back when on mycroft.

Would that work?
Priority: P3 → P4

Comment 3

14 years ago
This affects l10n, PR or bust.
Flags: blocking-aviary1.0PR+
Flags: blocking-aviary1.0-
Flags: blocking-aviary1.0+
Whiteboard: affects l10n
- Changing bug to incorporate other sherlock files.  
- Resetting priority levels.
- Reassigning to blake.

---
Based on Mycroft Top 10, let's bundle these so users don't have to download
since they're already doing it.

Default list should be:
- Google (default)
- Yahoo 
- Amazon
- eBay 
- Dictionary.com
Assignee: bugs → firefox
Status: ASSIGNED → NEW
Priority: P4 → --
Summary: Ebay Sherlock Item → Add Sherlock Plug-ins to Search Drop down
*** Bug 256779 has been marked as a duplicate of this bug. ***
Created attachment 156932 [details]
Dictionary.com

Updated

14 years ago
Attachment #156931 - Flags: review?

Comment 10

14 years ago
Rafael, I also need the .gifs to display in the search bar.
Whiteboard: affects l10n → [waiting on gifs from rafael] affects l10n
Created attachment 156946 [details]
images

Here you go.

Comment 12

14 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 13

14 years ago
This was backed out because this wasn't completely checked in the first time and
it broke the build. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 14

14 years ago
Should be fixed now.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 15

14 years ago
adding "fixed aviary" keyword to pull this off of the open blockers list.
Keywords: fixed-aviary1.0

Comment 16

14 years ago
*** Bug 235493 has been marked as a duplicate of this bug. ***
Created attachment 157116 [details]
creative commons search plugin
Created attachment 157117 [details]
creative commons icon
Sorry guys, but I have one more: Creative Commons.  It's always been the plan to
include this when it was ready.  Today when I told them they were missing the
boat for the PR, they told me that they had just launched their search engine
two days ago, and they sat down and create the sherlock files (attached).  

Can we add that in?

Thanks.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 157121 [details]
creative commons search plugin (minor tweak)
Attachment #157116 - Attachment is obsolete: true

Comment 21

14 years ago
(In reply to comment #4)
> Based on Mycroft Top 10, let's bundle these so users don't have to download
> since they're already doing it.

How come these five are being bundled when Wikipedia is is at #5 and Amazon.com
just at #10? Wikipedia is obviously far more popular. :-/

In my opinion, IMDb would also be nice to have. It's at #6 right now.

I'm not for throwing just about everything in, but it would be nice to have a
broad range of engines included by default for new users. We'd get music album
and other product info from Amazon, movies from IMDb, an awesome encyclopedia
from Wikipedia.

I could personally be without Yahoo since I don't see what that one offer in
addition to Google, but maybe it's there for its popularity alone.

Comment 22

14 years ago
I agree that adding more options than google is a good idea. 

But I'm not happy about the choice just to add the most popular search engines
to the list.

Ebay and Amazon may be of benefit in the U.S.A but are irrelevant in other parts
of the world. I think you should use search engines that are used all over the 
world. Creative Commons may be useful for certain people but most people would
not have any use for it. Perhaps IMDb and Wikipedia would be good choices to the
list.

Localized builds of Mozilla Firefox could have their own relevant search
engines. But what about people that want an English Firefox but don't want Ebay
and Amazon on the list?

One idea I got from a chat on IRC was to specify in the installer what search
engines that should be installed.

Furthermore I think it's a bad idea to get this code into Firefox before there
is an easy way to uninstall unwanted search engines from the drop down list.

Comment 23

14 years ago
More Wikipedia, less Yahoo!

Comment 24

14 years ago
I agree with Jacob on this one.  I think that the Creative Commons one shouldn't
be in there.  It's actually the first time I've heard of this site.  I think
Wikipedia would be a big plus, and so would IMDB.  As far as ebay and amazon go,
I don't have a major problem with them, but I think Jacob is right in saying
that it might not be of use to all users, wheras Wikipedia and IMDB certainly
would be.  As far as Yahoo goes, Google is a superior search engine anyway, so
I'm not sure why we have to have two plugins which are doing pretty much the
same thing.

Comment 25

14 years ago
http://search.creativecommons.org/ i just skimmed that thing and have no idea
what it does. Search for Microsoft bring up ****(looks like blogs) Why would you
search for info from blogs anyways? If you're that advanced you might as well
search for microsoft blogs

In my opinion

Google=for popularity and functionality
Yahoo=for popularity and google's twin (plus here, minus there)
Wikipedia=foreigner-friendly, like a free Encarta, informative
Amazon/Yahoo Shopping/Froogle=Never trusted Ebay, even though I never tried it.
Dictionary=sure, ok

Unless Creative Commons paid you, no need for them.

Comment 26

14 years ago
I agree. Creative Commons shouldn't be in the search bar. Please make the case
for it and reopen the bug if so inclined.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
The request to add Creative Commons is the result of a meeting between Mozilla
staff and Creative Commons staff this spring.  Adding this search engine is near
and dear to Mitchell and myself.  Creative Commons is an important 'spiritual
brethern' of the Mozilla project.  Their search engine allows people to find
content on the web that can be freely redistributed.  This is useful not just to
open source fans but also to enterprises users who want to find content that can
be legally distributed.  And the entry balances out the commercial offerings on
the list.

Please add.  Blake, pls contact me directly if you'd like to discuss this further.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 28

14 years ago
I still don't think it should be in there.  Firefox's purpose is to serve its
users as best it can, and I don't think Creative Commons has a very wide appeal
amongst your average IE convert.  Keep in mind that, presently, Wikipedia isn't
in there either, and I think that's a much more valid, and useful (for most
users) project which should be included.  Creative Commons just shouldn't be a
priority.  It's nice that the plugin is available, but distribute it thorough
mycroft, where those who really need/want it can get it.  This shouldn't be part
of the standard package destined for your average joe.
I think Bart outlined the reasoning for this addition quite well.  No more
discussion should be necessary.

btw:   wikipedia may be a great addition, and keep with the spirit of this bug.

Comment 30

14 years ago
Is there any chance that bug 203959 ( web search for <selected text> should use
searchplugin box )could be fixed now that Mozilla has decided to add more search
engines?

I'm a big user of right clicking some text and then make a "search web for" . 
Most of the times I use Google. But I also have an extensiom from Pikey called
"Web Search Plus" that allows me to use another search engines from the drop
down list when right clicking some text. That extension does basicly what is
described in 203959.  

For example i can read a tv listing and and easily do a websearch on IMDb to
learn more about a cerain movie. Or while doing some research I can easily do a
search in the Wikipedia.

Pikey has removed his site and the extension is also removed on the Mozilla
Update Site. So it's not possible for new users to get the benefits.

My conclusion: To really make benefit from several search engines in the "
google search box" it is necessary to be able to rightclick and do a web search
on the currently chosen search engine.

Updated

14 years ago
Attachment #156931 - Flags: review?
to ben since blake is on vacation.
Assignee: firefox → bugs
Status: REOPENED → NEW
can we get this done pls?  this is a PR blocker.  
Comment on attachment 157117 [details]
creative commons icon

There is a patch, it needs review.
Attachment #157117 - Flags: superreview?(bugs)
Attachment #157121 - Flags: superreview?(bugs)
Created attachment 158039 [details]
Wikipedia Icon

I think Wikipedia would be *extremely* useful, and relevent.  As much so as any
search engine added so far, if not more.  So attaching an icon (from their
favicon), as well as a search .src file I made up based on looking at Google
and Dictionary.com (haven't done search plugins in ages now, they are fun).

.src coming
Created attachment 158040 [details]
Wikipedia Search Plugin
Attachment #158039 - Flags: superreview?(bugs)
Attachment #158040 - Flags: superreview?(bugs)
I agree with many of the posters here that wikipedia would be a great addition
but I am extremely suprised to see Amazon and ebay on the pre-installed list -
why should amazon get preferential treatment over any other book/CD retailer?  

Dictionary.com, google, wikipedia and for that matter IMDB which is an
Amazon-operated site all provide useful free services to the community.
Amazon.com and Ebay are both essentially Amercian stores and of no interest to
the rest of the world don't deserve preferential treatment over their competition.
 

Comment 37

14 years ago
One thing that might be interesting to note, Wikipedia is now in the Firefox
Crew Picks in the new bookmarks.html file that will be checked in.  Why not have
it in the search bar, too?  Makes sense...
Hi folks,

Agreed on wikipedia.  Let's remove Dictionary.com and replace it with Wikipedia.  

Reasons:
- dictionary.com is commercial
- dictionary.com serves a (OUCH!) popup
- dictionary.com is hard to localize
- wikipedia is cool
- wikipedia is non-profit, community-based, like Mozilla
- wikipedia is localized
- wikipedia is similar to dictionary in terms of the reason for putting it in
the search pulldown: it shows the breadth of the search box pulldown.

Also, thanks to Blake for checking in the Creative Commons plugin.  Keep
checking the CC search page over the next days.  They're making it more
userfriendly!
Mucho agreed Bart!

Can you get someone to review my Wikipedia Plugin I posted?  It's assigned to
ben for review right now, but I assume he's busy (as usual).

Comment 40

14 years ago
-> me
Assignee: bugs → firefox

Comment 41

14 years ago
We have decided not to add Wikipedia. An encylopedia is not a replacement for a
dictionary. Someone could try to make a case that searching an encyclopedia is
so common that we should offer it in the search bar, but I personally don't
believe that to be so.
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Blake, then why not make it in addition?

The internet is still a research tool for many if not most general users.  A
dictionary isn't exactly research.  I'd bet more people want to research 'goats'
than lookup words.

It's also a great advantage for educational markets to have built in searches
for Google, Wikipedia, and Dictionary.com

Searching for information is still a key aspect of the web (look at Google, and
how Micro$oft wants to own search by the time Longhorn ships).  An encyclopedia
has been a major resource of information.

May also want to look at:
http://en.wikipedia.org/wiki/Wikipedia:Statistics#Traffic

to see how wikipedia is growing by leaps and bounds.
A couple things: 
 - Wikipedia isn't a search engine,uses Google and Yahoo to do the search within
the wikipedia domain.
 - Wikipedia is part of the default bookmarks in two! places, quick search and
as part of the picks.

Dictionary.com while commercial is a good resource and is the second most
popular plug-in at the mycroft download site (so should be included).
Rafael:  May want to try the plugin I wrote, it uses Wikipedia's keyword like
interface.  

If it finds a result, it returns the page itself.  Not a search index.  

So by having it in the search box... you essentially have no results page.  You
can go right to the information.  

Comment 45

14 years ago
Wikipedia's search currently only looks for exact matches in the database, due
to performance issues with their search.  If it finds no results, it will allow
you to search the site using Yahoo or Google, yes, but I believe this is only
temporary until they upgrade their servers more.  This doesn't make it any less
of a valuable ressource, however.

Comment 46

14 years ago
I believe that Wikipedia would be a good addition to the search bar. This would 
appeal to K-12 students, as well as higher education students. I, myself, am a 
college student and right off I would never know this to be a possibility for 
FireFox. Maybe it is something you can consider for the official release.

Thanks
Creative Commons isn't in.  Need to get this checked in.
Status: RESOLVED → REOPENED
Flags: blocking-aviary1.0- → blocking-aviary1.0?
Resolution: FIXED → ---
Whiteboard: [waiting on gifs from rafael] affects l10n → affects l10n
+'ing per Ben.  Fixes in hand, just need to get checked-in:

1) Updated Amazon plug-in w/ correct mozilla tag.
2) Creative Commons image and plug-in needs to be checked-in 
Assignee: firefox → bugs
Status: REOPENED → NEW
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Summary: Add Sherlock Plug-ins to Search Drop down → Fix sherlock plug-ins
Whiteboard: affects l10n → affects l10n, [fix in hand]
Created attachment 160415 [details]
Correct Amazon.src file
Attachment #156931 - Attachment is obsolete: true

Updated

14 years ago
Attachment #160415 - Attachment description: New correct file → Correct Amazon.src file
totally my bad on the no checkin on creative commons.  Blake asked me to do
that, but I haven't really had time with a tree to do something about it. 
Should get that in tonight.

Comment 51

13 years ago
Can wikipedia be reevaulated for inclusion, now that the crew-picks folder now
longer exists?

Comment 52

13 years ago
I'd also love to see Wikipedia in for the release.  I think it's a very useful
tool to pretty much everyone, and is a great example of the open-source spirit.

Comment 53

13 years ago
Is thei place to report that Yahoo plug-in does not support UNICODE characters
(tested on ижљр)?

Comment 54

13 years ago
Fixed on trunk by the aviary landing.
Bug 286034 will remove the Dictionary.com and add the answers.com searchplugin.
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: affects l10n, [fix in hand]

Updated

13 years ago
Attachment #157117 - Flags: superreview?(bugs)

Updated

13 years ago
Attachment #157121 - Flags: superreview?(bugs)

Updated

13 years ago
Attachment #158039 - Flags: superreview?(bugs)

Updated

13 years ago
Attachment #158040 - Flags: superreview?(bugs)
QA Contact: search
You need to log in before you can comment on or make changes to this bug.