Full filename of download does not appear when filename has spaces in it.

VERIFIED DUPLICATE of bug 221028

Status

()

--
major
VERIFIED DUPLICATE of bug 221028
15 years ago
11 years ago

People

(Reporter: mail4ed, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When I attempt to download files (from secure site) that contain spaces in the
filename the full filename is not selected.  The download dialoge box only shows
up to the first space.  For example, if I try to download "test file.doc" only
"test" shows up.  This also prevents me from launching the file with Word
(simular for any other extention).

Reproducible: Always
Steps to Reproduce:
1.Click the file to download (with spaces in filename).
2.
3.

Actual Results:  
Download dialoge only shows the filename up to the first space.

Expected Results:  
Shown the entire file name and offered a choice of launching the file with the
correct application.

Comment 1

15 years ago
This is almost certainly invalid because the server's Content-Disposition HTTP
header is not quoted, and it needs to be if you're going to get the full
filename, otherwise it will only parse the part before the first space.

Can you provide a URL, or confirm for yourself if the Content-Disposition header
is quoted or not and let us know?
(Reporter)

Comment 2

15 years ago
I'm not sure how to get the Content-Disposition header.  The website requires a
login so you won't be able to access it yourself unfortunatly
(webct.ics.purdue.edu).  I do know that the full filename does show up whenI use
Internet Explorer 6 and that it does show the extention, which allows me to
launch the file directly.  If there is an uncomplicated way to get the
Content-Disposition header, let me know and I will try.  

Comment 3

15 years ago
I don't know if this falls under your description of uncomplicated, but here goes:

If you install the LiveHTTPHeaders extension (from
http://livehttpheaders.mozdev.org/), and open the LiveHTTPHeaders window from
the Tools menu after you restart Firefox, you'll see an empty window open. When
you click on links, it will dump the HTTP headers to the window. When you click
on the link to the file in question, you should see the headers for that file,
and there should be a Content-Disposition header there. The filename should be
quoted (but I expect that it's not). If its not, then its a server side problem,
and the bug is invalid. If it is quoted, then its likely a problem on our end.
(Reporter)

Comment 4

15 years ago
Yeah, I'd say it was pretty easy.  I appriciate it when you guys make stuff
friendly for the rest of us non techie people.  Thanks!

Here are the results from the Live HTTP Headers tool.  It looks that the
content-disposition header is not quoted.



HTTP/1.x 200 OK
Date: Sat, 08 May 2004 17:07:23 GMT
Server: Apache/1.3.26 (Unix) mod_perl/1.26 mod_ssl/2.8.10 OpenSSL/0.9.6d
content-disposition: attachment; filename=Syllabus w lab V2.doc
Keep-Alive: timeout=2, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: application/download

Comment 5

15 years ago
Thanks, that confirms what I suspected.

*** This bug has been marked as a duplicate of 221028 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.