Last Comment Bug 242834 - I wish that I could enter a bookmark keyword into the Save Bookmark dialog
: I wish that I could enter a bookmark keyword into the Save Bookmark dialog
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: All All
: -- enhancement with 2 votes (vote)
: Future
Assigned To: Mike Connor [:mconnor]
:
Mentors:
: 273900 277667 345239 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 12:52 PDT by Sophia Poirier
Modified: 2007-04-18 06:15 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Sophia Poirier 2004-05-06 12:52:36 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040506 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040506 Firefox/0.8.0+

I wish that I could enter a bookmark keyword into the Save Bookmark dialog.  I
wisht that there were a field for that in the dialog.  That would be so convenient.

Reproducible: Always
Steps to Reproduce:
1.  Save Bookmark.
Actual Results:  
no field for bookmark keyword

Expected Results:  
a field for entering a bookmark keyword
Comment 1 Bill Mason 2004-05-06 12:55:59 PDT

*** This bug has been marked as a duplicate of 89001 ***
Comment 2 Jesse Ruderman 2004-06-24 14:05:09 PDT
The Bookmarks UI is different in Firefox and Seamonkey, so this isn't a dup of a
Seamonkey bug.
Comment 3 Mike Connor [:mconnor] 2004-06-24 14:42:13 PDT
the one issue with this is that we don't want this for normal users.  Second, if
you're creating a bookmark from a search field, it does allow you to choose the
keyword already, so this is only really needed if you're just looking to add a
keyword for a "normal" bookmark, which is pretty much an edge case.  Still, it
bears some examination, but after 1.0, when I want to take a look at how we add
bookmarks.
Comment 4 Sophia Poirier 2004-07-06 10:28:22 PDT
(In reply to comment #3)
> the one issue with this is that we don't want this for normal users.

Given that there's already a sort of "advanced" or "expanded" mode (when you
click the widget to view the bookmarks sub-folders), I figured that it could be
something that is only exposed there.

> Second, if you're creating a bookmark from a search field, it does allow you 
> to choose the keyword already, so this is only really needed if you're just 
> looking to add a keyword for a "normal" bookmark, which is pretty much an 
> edge case.

Huh, it doesn't seem like an edge case to me.  I guess it's a matter of working
style, but I only ever do "normal" bookmarks, and very often want to add a
keyword when I do so.  Hence my filing of this enhancement request...
Comment 5 Greg K Nicholson [:gkn] 2004-07-23 09:47:10 PDT
The extension OpenBook (http://update.mozilla.org/extensions/moreinfo.php?id=42)
provides a Keyword field. It doesn't yet provide fields for other bookmark
properties.
Comment 6 Asa Dotzler [:asa] 2004-07-23 13:01:16 PDT
wontfix.
Comment 7 PikeUK 2004-12-09 07:56:46 PST
*** Bug 273900 has been marked as a duplicate of this bug. ***
Comment 8 Mike Connor [:mconnor] 2005-01-09 14:57:07 PST
*** Bug 277667 has been marked as a duplicate of this bug. ***
Comment 9 Phil Ringnalda (:philor) 2006-08-10 22:07:48 PDT
*** Bug 345239 has been marked as a duplicate of this bug. ***
Comment 10 Mike Connor [:mconnor] 2006-08-27 05:08:25 PDT
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
Comment 11 Chris Wood 2007-04-18 06:15:20 PDT
Add Bookmark Here 2 (https://addons.mozilla.org/en-US/firefox/addon/3880) also does this.

Note You need to log in before you can comment on or make changes to this bug.