One additional click is required to get focus at appropriate place.

RESOLVED DUPLICATE of bug 126379

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: Neelesh K Sharma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

For getting focus through keyboard is taking one additional tab, as it takes 
through mouse.

Reproducible: Always
Steps to Reproduce:
1) Load the file in the browser                                
2) Tab to the drop down box and cycle to another color,        
3) Tab to the next box                                         
At this point the color changes from the onchange event.    
As if  you use the mouse                                              
1) Load the file in the browser                                
2) use the mouse to slect a different color                    
At this point the color does change before moving to the other box.
                                   

Actual Results:  
Colour is not changing,  as it changes while using mouse

Expected Results:  
Colour should change,  as it changes while using mouse

I have tested this problem in different versions of mozilla from 1.1 to 1.7b 
on OS2, Problem could be seen everywhere.

   Even problem can be seen in mozilla 1.7b on WINDOWS XP.
(Reporter)

Comment 1

13 years ago
Created attachment 147865 [details]
Testcase
(Reporter)

Updated

13 years ago
OS: Windows XP → OS/2
If you drop the dropdown down with keyboard (like you do with mouse), then the
onchange will fire when the dropdown rolls up.  If you just use arrow keys, you
haven't made a selection till you tab out or hit enter.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.