Fixed-position TEXTAREA scrollbar repaints incorrectly when page scrolled

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: Brion Vibber, Unassigned)

Tracking

({classic, testcase})

Trunk
PowerPC
Mac OS X
classic, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040506 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040506 Firefox/0.8.0+

If there exists a page element with style position:fixed, then the scrollbars on
non-fixed elements such as <textarea>s are not repainted correctly when the page
is scrolled.

The element scrollbars seem to remain one step behind the rest of the page,
which can be a huge screen distance for pageup/pagedown. Mousing over or
clicking the scrollbars causes them to repaint, though the page area around them
may remain corrupted.

Changing the position:fixed to position:absolute removes any problem with the
scrollbars.


Reproducible: Always
Steps to Reproduce:
1. Visit a page with a position:fixed element and a non-fixed textarea, such
that both the page and the textarea have scrollbars.
2. Scroll the page.

Actual Results:  
<textarea>'s scrollbar lags behind the rest of the page, corrupting display.

Expected Results:  
<textarea>'s scrollbar should remain exactly in step with the other scrolled
page elements.

Using default Pinstripe theme; Mac OS X 10.3.3.

Updated

14 years ago
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: general
Version: unspecified → Trunk
This worksforme with a current Linux build using Modern theme...

Comment 2

14 years ago
Confirmed using Mozilla-Mac/1.7b. Classic only.
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: Form Controls
Ever confirmed: true
Keywords: classic, testcase
QA Contact: general → core.layout.form-controls
Summary: Textarea scrollbar repaints incorrectly when page scrolled with position:fixed → Fixed-position TEXTAREA scrollbar repaints incorrectly when page scrolled

Comment 3

13 years ago
i've seen this behavior with a <textarea> not scrolling properly when the entire
page scrolls. as soon as the scrolling stops the <textarea> is repainted in the
proper alignment, but during the scrolling it appears to be at least 2px behind
the rest of the page in either scrolling up or down.

Comment 4

13 years ago
forgot to mention the platform was winxp sp2 with firefox 1.0
That's simply "native widgets suck"
Depends on: 352093
It works on WinXP. I can't reproduce Comment 3 behaviour with provided URL as well.
(Reporter)

Comment 7

6 years ago
Not seeing this problem on the same page in Firefox 8.0.1 / Mac OS X 10.7.2 (x86_64).

Closing out as WORKSFORME. :)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.