Wrong paper size selected if print operation is activated by web page.

RESOLVED DUPLICATE of bug 118563

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 118563
14 years ago
14 years ago

People

(Reporter: Andi Voss, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.7b) Gecko/20040421 MultiZilla/1.6.1.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.7b) Gecko/20040421 MultiZilla/1.6.1.0b

Remark: This bug is similar to # 199319 but the other way. "My" bug was already
in the older versions of Mozilla.

Preface: In Europe the paper size is DIN A4 and therefore the printers are
installed with this size as default paper.

If a web page initates a print operation with the Java command "window.print()"
the paper size used is Letter and not the predefined A4. This causes several
printer to ask for each! page to continue ba manual action. If the paper is
corrected at the beginning of the first print the size ist maintained until the
terminatiuon of the browser process.

If the print is requested by "File - Print" or the Print-Button the right size
is used.

Have a look on the submitted website at the end of the text (Printer symbol and
"Drucken").

Reproducible: Always
Steps to Reproduce:
1. Open your printers properties and change the paper size to anything but
Letter. This step is important!
2. Open given website and klick "Drucken". 
3. In the properties window of the printer check the paper size. its different
to the predefind (step 1) size.

Actual Results:  
On some printer manual correction is necessary for each! page.

Expected Results:  
Using the paper size defined in the printer properties.
Summary: Wrong paper size selected if print operation is actvated by web page. → Wrong paper size selected if print operation is activated by web page.

Comment 1

14 years ago
It is probably a dupe of bug 118563
It also looks like bug 243012
(Reporter)

Comment 2

14 years ago
Well, it looks very similar to bug # 118563.

SCNR but I have to ask: Why has this bug not yet fixed??? It is known as bug #
118563 since 2002-01-07 - that are more than 28 months!!!!

Andy
(Reporter)

Comment 3

14 years ago
For your information: The bug is in the version 

Mozilla 1.8a1
Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.8a1) Gecko/20040520
MultiZilla/1.6.4.0b

still "available"..

Andy

Comment 4

14 years ago
WFM LInux 2004061405  This seems to have been fixed for linux around bug 118563
comment 53.
I don't know if this applys but I did find this odd bug in bug 185920 comment 22.

*** This bug has been marked as a duplicate of 118563 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.