Remote calendars fail to load.

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: sudzer, Assigned: mostafah)

Tracking

({regression})

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 2004040813-cal on thunderbird 20040505 0.6+

If I subscribe to a remote calendar, it shows up in the calendar's list but the 
2 circling red arrows continue to move, and not calendar shows up.  Logs on the 
webdav server show it was requested, but it does not show up.  Same calendar 
works fine with cal xpi under netscape 7.1



Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
I see a very similar thing. I have not tried subscribing to new remote
calendars, but opening a Calendar when already subscribed to some remote
calendars results in the "reloading arrows" constantly spinning and the calendar
never being updated. Manual "refresh remote calendars" does not help. Web server
logs show that the HTTP request succeeded.

This appears to be a relatively recent regression, at least port-1.7 branch.
Remote calendars load fine with 2004050518 1.7 branch build, but fail to load
with 2004050521 trunk build.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All

Updated

15 years ago
Summary: When subscribing to a remote calendar the arrows contiunally show that it is downloading, but not cal shows up → Remote calendars fail to load.
(Assignee)

Comment 2

15 years ago
The fix to bug 241092 has caused this.
See http://bugzilla.mozilla.org/show_bug.cgi?id=241092#c11

Updated

15 years ago
Depends on: 241092
this might be as simple as using:
 var my_string = String.fromCharCode.apply(this, result);
at the top of the onStreamComplete function, and using my_string instead of
result after that.

but be aware that you will get wrong results with any non-ascii data (and got
before).
(In reply to comment #4)
I'm not sure this info would be helpful here...

String.fromCharCode.apply(this, result) fails if resultLength is
larger than the magic number "65535".
(Assignee)

Comment 6

15 years ago
Reopened then
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Anybody confirmed?

My workaround is

const TEMP_MAX=32*1024; // smaller than 64K
var str="";

while(result.length > TEMP_MAX)
  str +=String.fromCharCode.apply(this, result.splice(0,TEMP_MAX) );
str += String.fromCharCode.apply(this, result)

There's no problem so far,
but I don't know what happens if result[TEMP_MAX-1] is
non-ascii char.

Comment 9

14 years ago
I am sorry but I was not able to understand what I need to do get remote
calendar to work for me. I was able to create and post a new remote calendar but
when I try to upload this on a different machine, I get a message that says it
is not a valid file. I have tried this on SUNOS, Windows 2000, Windows XP Pro. I
have tried this on Firefox 0.9, 0.9.2, 0.93, Mozilla 1.7b. I have tried the FTP
option and the HTTP option.

Can someone explain a little bit more clearly on what I should do to get this to
work. I would like to synchronize between home and work. I also need to
synchronize one calendar for an organisation I volunteer for. I do not have
administrative priviledges on my SUN machine but have this on all other OS.

Comment 10

14 years ago
This is happening to me as well on the 080904 build.

If I delete the "Calendar" folder in my Thunderbird profile and then 
resubscribe to the remote calendar, it will work for that session.  As soon as 
I close calendar, however, it's game over.  The next open will cause the 
calendar to never be refreshed (as a matter of fact, it's blank) and when I 
close Calendar, *everything* (including Thunderbird) crashes.  I've sent the 
crashes back to the feedback agent too, btw.
(Assignee)

Comment 11

14 years ago
Vermyndax:
Make sure you are not using an older version of the calendar extension
by following the uninstall instructions at:

http://www.mozilla.org/projects/calendar/faq.html#uninstall_info

If after doing this thunderbird fails to launch, delete the chrome.rdf file, the
xpti.dat file and the compreg.dat file from your thunderbird profile directory.

Comment 12

14 years ago
I can't get it to work here.
I'm putting a password-protected ftp url in like
ftp://username@ftp.myftp.com/calendar.ics. Refreshing the remote calendar opens
firefox (my default browser) which then asks for the ftp password, and after
entering it opens the ics file. Publishing the calendar does never work, and
using the manual publish (rightclick > publish entire calendar) doesn't do anything.

Comment 13

14 years ago
Problem publishing Calendar to webdav and work with it from Linuxclient

I published a calendar file (~80kB) to a webdav Server from a windows based
mozilla 1.7.3 (at work) and I was able to work with it.
Now i tried to subsribe this calendar from a Linux based Mozilla-Calendar (at
home) and failed.
I looked a the calendar files an realised that the file at the webdav server was
in DOS Format (CR/LF). The calendar files at my Linux-Box are in Unix format.
Also if i publish a calendarfile from my linux-box to webdav it is in DOS-Format.
It seems to  me that the linux-based calender can't read this files.
Perhaps this helps.
If I'm wrong, excuse me.
detlef

Comment 14

14 years ago
Mmm... only problem is, this calendar file worked fine in KDE 3.2.3...

Comment 15

14 years ago
(In reply to comment #5)

Is this why I can't completely see remote calendars whose file size is bigger
than 64k? I tried to include a remote *.ics in the latest sunbird-W32 release
and only the first entries where displayed. Looking at the local file shows that
only the first 65536 bytes where saved and displayed.

BTW: it works pretty well with the mozilla calendar extension on Mozilla 1.7
(can't say which exactly build this is right now)
the 64k issue is bug 248884.
It seems this bug is worksforme now.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.