Closed Bug 243008 Opened 20 years ago Closed 20 years ago

Latest 1.7 branch installer busted: "Quality Feedback Agent: -214 DOES_NOT_EXIST"

Categories

(SeaMonkey :: Installer, defect)

Other Branch
x86
Windows XP
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzillamozilla, Assigned: leaf)

Details

(Keywords: regression, verified1.7)

Attachments

(2 files)

Installation aborts with the above error (screenshot is coming).

To reproduce:
1. Download http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.7/
-> mozilla-win32-installer.exe (07-May-2004 19:34  11.5M)
2. Install the package using the default settings

I verified this to happen on two different computers.

Prog.
Attached image Screenshot of the error
Come to think about it, this bug "Blocks development and/or testing work", so
changing Severity to match.

Prog.
Severity: major → blocker
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040506

last directory including talkback, 301kb, installing without error:
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-05-06-09-1.7/
mozilla-win32-installer.exe       06-May-2004 16:30   12M 
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-05-06-09-1.7/windows-xpi/talkback.xpi
talkback.xpi            06-May-2004 12:30   301k 

directories including talkback-dummies, showing this bug:
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-05-07-10-1.7/
mozilla-win32-installer.exe       07-May-2004 17:22   12M
talkback.xpi            07-May-2004 13:21     1k  

http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-05-07-16-1.7/
mozilla-win32-installer.exe       07-May-2004 23:34   12M
talkback.xpi            07-May-2004 19:34     1k
Should have been fixed by Bug 240234, maybe not all tinderboxen got changed.
Leaf: Don't have the 1.7 branch tinderboxen this workaround with the dummy
README file?
Assignee: general → leaf
(In reply to comment #4)
> Should have been fixed by Bug 240234, maybe not all tinderboxen got changed.
> Leaf: Don't have the 1.7 branch tinderboxen this workaround with the dummy
> README file?

It is a regression, 
last build     including Talkback: 1.7: 2004050607
last build not including Talkback: 1.7: 2004050715

link to a dummy talkback.xpi from a not-working build:
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-05-07-16-1.7/windows-xpi/talkback.xpi

The directories I mentioned in comment 3 are regular nightlies for windows,
so may be we should mark this as regression, and dupe it to reopened
Bug 240234 	-214 DOES_NOT_EXIST error while installing talkback 	

I'm using now the zip build, and it is working fine:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040507

I unpacked an exe, extracted talkback.xpi, unzipped it to install.js
and compared to talkback.xpi unzipped from folder windows-xpi, and a
talkback.xpi unzipped from tinderbox Creature

There is no difference in the 1.7 dummys, besides the revision string.
There is a difference between 1.7 dummys and 1.8a dummy from Creature:

srDest = 97;
...
if(verifyDiskSpace(communicatorFolder, srDest))
{
  setPackageFolder(communicatorFolder);

  upgradeCleanup();
  err = addDirectory("",
                     "1.8.0.2004050806",
                     "bin",              // dir name in jar to extract 
                     communicatorFolder, // Where to put this file (Returned
from getFolder) 
                     "",                 // subdir name to create relative to
communicatorFolder
                     true );             // Force Flag 
  logComment("addDirectory() returned: " + err);

  // check return value
  if(!err)

...

Talkback.xpi for 1.8a unzips to a file install.js and a folder bin, holding a
Readme.

This folder bin and the readme is missing in the 1.7 talkback dummys,
but used in the code above.

The other difference is, that var srDest is 97 for 1.8a, and 1 only for 1.7
the working 4kb talkback.xpi dummy from Trunk tinderbox Creature contains
install.js and a folder bin, holding a 10kb readme.txt

the not-working 1 kb talkback.xpi from 1.7 nightly contains the attached
install.js only, and I guess the lacking folder bin is triggering the error.
Talkback.xpi is missing bin/readme.txt, and that triggers the error.

I unzipped the failing mozilla.exe into a folder, deleted the 1 kb sized
talkback.xpi, and  replaced it with a 5 kb sized talkback.xpi from a windows-xpi
folder from Creature, or look into
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-05-08-09-trunk/windows-xpi/

I started Setup.exe in this folder, and had a normal installation.
Keywords: regression
I believe this bug is Fixed. The windows installer builds install just fine and
Talkback is working.
Status: NEW → RESOLVED
Closed: 20 years ago
Keywords: fixed1.7
Resolution: --- → FIXED
Today's (5/12's) stub installer (run on Win 98) errors out with this message:
"The SETUP.EXE file is linked to missing export SHELL32.DLL StrStrlA." 

Is that a different regression?
I get the same error with the full installer.
I also get the same error on the 1.8a nightly trunk build stub installer. I'm
not getting that error on the 1.6 stub installer.
Leaf, is this fixed? I can't reproduce on windows XP with the latest branch
build but others are claiming it's still a problem. 
Status: RESOLVED → REOPENED
Keywords: fixed1.7
Resolution: FIXED → ---
(In reply to comment #9)
> Today's (5/12's) stub installer (run on Win 98) errors out with this message:
> "The SETUP.EXE file is linked to missing export SHELL32.DLL StrStrlA." 

Bug 243373  	StrStrI symbol not found
Thanks.
this bug has been confused for 243373. talkback was busted for a few days, it's
back online for platforms where the installer functions normally.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Keywords: fixed1.7
I won't reopen this without confirmation, but it seems that today's build -
mozilla-win32-installer_2004-05-20-09-1.7.exe - seems to be busted by missing
talkback again.
Reopening. I also see this problem in the latest nightly:
...latest-1.7/mozilla-win32-installer.exe 20-May-2004 16:46

Prog.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: fixed1.7
This is fixed now.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Keywords: fixed1.7
Resolution: --- → FIXED
That's presumably fixed as in "talkback is working again" rather than fixed as
in having the readme file so it won't break again next time talkback doesn't get
hooked up for a build, right?
Verified as fix on latest 1.7 branch 06-24 build on WinXP
Changing keywords from fixed1.7 to verified1.7.
Leave this bug status "as is" until this bug be verified on trunk again...
Keywords: fixed1.7verified1.7
Product: Browser → Seamonkey
I have gotten this error message with Firefox for months when installing the
nightlies.  File a new bug?
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: