Negative age-in-days value is required to filter spams came from future

RESOLVED DUPLICATE of bug 174294

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 174294
14 years ago
10 years ago

People

(Reporter: World, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040509
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040509

Negative value of age-in-days is accepted by UI but converted to large positive
integer.
This causes difficulty in filtering spam mails from future.
Change age-in-days to signed data, please. 

Note: "Age-in-days less than 0" works well on both today's mail and future mail
currently.



Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Dupe of bug 174294?
(Reporter)

Comment 2

14 years ago
If solution for bug 174294 satisfies my want, this bug is dup of bug 174294.
But fix for bug 174294 can be "Do not allow negative number in UI".
The possibility of this is not zero, my experience says :-)
(Reporter)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 174294 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.