My credit card is remembered with Autocomplete and easily accessible to anyone that uses my browser

VERIFIED DUPLICATE of bug 188285

Status

()

Firefox
Address Bar
--
critical
VERIFIED DUPLICATE of bug 188285
14 years ago
2 months ago

People

(Reporter: Devin Henderson, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040430 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040430 Firefox/0.8.0+

Autocomplete should not remember 15 or 16 digit numbers (credit card numbers).
As it stands, my card number is recorded by Autocomplete when I enter it into a
CC # field. From then on, other fields with the same name pop up my credit card
number as an Autocomplete option. This means that anyone using my browser can
automatically fill their shopping cart form with my credit card number. On top
of that, it is being stored in Firefox, wherever other Autocomplete information
is stored. This should not happen.

Reproducible: Always
Steps to Reproduce:
1. Enter your credit card number into a CC # field and submit.
2. Visit the same shopping cart again and notice that the CC # is an option in
the Autocomplete drop down box.
3. This also happens on other sites, where their CC # field uses the same name
(could be several sites)

Actual Results:  
My credit card number was stored as an Autocomplete option

Expected Results:  
Autocomplete should check for 16 (Visa, MC, Discover) or 15 (Am. Express) digit
numbers and not save them.

I consider this a very serious issue--one that I would hate to see unresolved
for Firefox 1.0.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 188285 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
I wouldn't have Wontfixed that dupe, but there you go. 
 
v. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.