Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 243648 - Make copy&paste work better in Chatzilla
: Make copy&paste work better in Chatzilla
Status: RESOLVED DUPLICATE of bug 12460
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: x86 Windows 2000
: -- enhancement (vote)
: ---
Assigned To: traversal-range
: Hixie (not reading bugmail)
: Jet Villegas (:jet)
Depends on:
  Show dependency treegraph
Reported: 2004-05-14 14:26 PDT by Frank Wein [:mcsmurf]
Modified: 2013-04-04 13:53 PDT (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Frank Wein [:mcsmurf] 2004-05-14 14:26:08 PDT
First i think the problem is more than just c&p, but I don't know the Chatzilla
code so good to know what's wrong here.
When you mark some chat log and copy it into the clipboard you get:
xyz	you probably want --enable-crypto as well
	abc	do I need to do a 'make clean' or something?
	abc	I already built once without these options
	xyz	yeah, that'd be a good idea
	abc	thanks guys

So first i would like that Chatzilla also copys the < > around the nicknames
into the clipboard.
And second that the tab key before the 2nd line until the end of the c&p will be
elimanted (also this could be a regression i would need to test with, at least
happens with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a)
Comment 1 Robert Ginda 2004-05-14 14:35:14 PDT
that's not a chatzilla problem.  The < and > characters are inserted with css
:before and :after rules, which mozilla doesn't include in the selection.

Taking a guess that DOM: Traversal-Range might be the correct component.
Comment 2 Frank Wein [:mcsmurf] 2004-05-14 14:55:11 PDT

*** This bug has been marked as a duplicate of 12460 ***

Note You need to log in before you can comment on or make changes to this bug.