Closed Bug 243692 Opened 20 years ago Closed 20 years ago

Bookmarks overflow menu should collapse when item is dragged out

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.7final

People

(Reporter: durbacher, Assigned: durbacher)

Details

(Keywords: verified1.7)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040501
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040501

Bug 201854 enabled drab and drop for the bookmarks overflow menu. However,
unlike other bookmarks folders this overflow menu does not collapse when an item
is dragged out of it. For consistency it should collapse (and of course reopen
if the item is dragged in again).

Reproducible: Always
Steps to Reproduce:
1. Drag an item... ah, forget it, it's all described already.




Patch is coming...
Attached patch patch (obsolete) — Splinter Review
Observe!
Assignee: p_ch → durbacher
Status: NEW → ASSIGNED
Comment on attachment 148573 [details] [diff] [review]
patch

Requesting r= from Neil and sr= from alecf.
Attachment #148573 - Flags: superreview?(alecf)
Attachment #148573 - Flags: review?(neil.parkwaycc.co.uk)
Comment on attachment 148573 [details] [diff] [review]
patch

>         document.getElementById("BookmarksMenu").parentNode,
>-        document.getElementById("PersonalToolbar")
>+        document.getElementById("PersonalToolbar"),
>+        document.getElementById("bookmarks-chevron-container")
Can't you do the parentNode trick on the chevron? Also, if you insert the new
element into the middle of the array it avoids changing the last line ;-)
Attachment #148573 - Attachment is obsolete: true
Attachment #148573 - Flags: superreview?(alecf)
Attachment #148573 - Flags: review?(neil.parkwaycc.co.uk)
Attached patch simpler patchSplinter Review
Comment on attachment 148615 [details] [diff] [review]
simpler patch

Requesting r= from Neil and sr= from alecf.
Attachment #148615 - Flags: superreview?(alecf)
Attachment #148615 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #148615 - Flags: review?(neil.parkwaycc.co.uk) → review+
Comment on attachment 148615 [details] [diff] [review]
simpler patch

Changing sr= request to jag.

alecf: of course you may still give me sr=...

jag: if you happen to be faster, could you please also take a look at bug
243961?

These two bugs are really nice-to-have for 1.7. Especially the other one really
should go in.
Attachment #148615 - Flags: superreview?(alecf) → superreview?(jag)
Comment on attachment 148615 [details] [diff] [review]
simpler patch

sr=jag
Attachment #148615 - Flags: superreview?(jag) → superreview+
Comment on attachment 148615 [details] [diff] [review]
simpler patch

Requesting approval for 1.7.

This is very low risk, and admittedly only somewhat visible.
Attachment #148615 - Flags: approval1.7?
Comment on attachment 148615 [details] [diff] [review]
simpler patch

a=asa (on behalf of drivers) for checkin to 1.7
Attachment #148615 - Flags: approval1.7? → approval1.7+
Fix checked in to branch and trunk.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Keywords: fixed1.7
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.7final
I cannot reproduce 2004052208-trunk/WinXP-JA 
thanks for fixing this.
Verified per last comment and own testing with current trunk nightly.
Thanky for spotting the inconsistency!
Status: RESOLVED → VERIFIED
Keywords: fixed1.7verified1.7
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: