Multiple Identities dialogue should have a Close instead of an OK button

VERIFIED FIXED in Thunderbird 13.0

Status

MailNews Core
Account Manager
--
trivial
VERIFIED FIXED
13 years ago
5 years ago

People

(Reporter: Constantine A. Murenin, Assigned: aceman)

Tracking

({polish})

Trunk
Thunderbird 13.0
polish
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
There is an OK button, but not a Cancel button in Manage Identities dialogue. 

In Account Settings, when you select Manage Identities, the newly appeared
Identities dialogue does not have a Cancel button. I think this flaw in UI
design, since other such dialogues in MailNews do have both OK and Cancel buttons. 

Neil suggested that one cannot undo changes to non-default identities from the
dialogue, so the solution might be to remove OK button and add a Close button
instead.

Comment 1

13 years ago
i'm not planning on supporting the cancel operation here.

a close button would be fine.

removing the bug dependency
Status: NEW → ASSIGNED
No longer depends on: 44863
Target Milestone: --- → mozilla1.8alpha

Comment 2

13 years ago
Can I also point out that the close operation is flawed... if you OK the Manage
dialog then the changes to the default identity get propagated back to the
account manager but if you just close the window they do not.

Comment 3

13 years ago
(In reply to comment #0)
> one cannot undo changes to non-default identities

Even to default identities: I just had removed my main mail address from an
account (using Thunderbird, but I presume it's the same). The second identity
settings came in to replace the account's ones.

I am not changing the severity of this bug myself but I strongly suggest to do
it as we have a data loss in just one click on "Delete". Raising (?) the flags
for the same reason.
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?

Comment 4

13 years ago
Thunderbird 0.8 is wrapped up. This will have to be considered for 0.9.
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-

Comment 5

13 years ago
minusing. not 1.0 stopper.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Product: Browser → Seamonkey
Assignee: mscott → mail
Status: ASSIGNED → NEW
Target Milestone: mozilla1.8alpha1 → ---

Comment 6

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 7

8 years ago
Moving to a better home.
Assignee: mail → nobody
Status: UNCONFIRMED → NEW
Component: MailNews: Account Configuration → Account Manager
Product: SeaMonkey → MailNews Core
QA Contact: account-manager

Comment 8

8 years ago
Comment #0 is invalid, OK and Cancel would be wrong there, as cancel would not undo all the changes one made in the dialog.

What we should do is follow comment #1 and comment #2 though, make the button be "Close" and make both ways of closing the window act consistently.
Summary: Multiple Identities dialogue should have both OK and Cancel buttons → Multiple Identities dialogue should have a Close instead of an OK button
(Assignee)

Updated

5 years ago
Assignee: nobody → acelists
Keywords: polish
(Assignee)

Comment 9

5 years ago
Created attachment 596398 [details] [diff] [review]
patch implementing comment 8

This works for me. I also remove gMessengerBundle while there, it seems unused.
Attachment #596398 - Flags: ui-review?(bwinton)
Attachment #596398 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Comment on attachment 596398 [details] [diff] [review]
patch implementing comment 8

Makes sense.  ui-r=me!

(Wow, 8 years to fix this.  Crazy.  :)

Thanks,
Blake.
Attachment #596398 - Flags: ui-review?(bwinton) → ui-review+

Updated

5 years ago
Attachment #596398 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

5 years ago
Attachment #596398 - Flags: review?(mbanner)
Comment on attachment 596398 [details] [diff] [review]
patch implementing comment 8

Review of attachment 596398 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/base/prefs/content/am-identities-list.js
@@ -157,5 @@
>    window.arguments[0].result = true;
>    return true;
>  }
>  
> -function onCancel()

You could actually remove the window.arguments[0].result assignment and adjust what the caller is doing in am-main.js to not bother with the result, but just update the account settings anyway.

However, I'm fine for that to be a follow-up bug/patch.
Attachment #596398 - Flags: review?(mbanner) → review+
(Assignee)

Comment 12

5 years ago
I do not yet understand this argument passing between dialogs so will better not touch that.
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/d7c6f47e41e1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0
(Assignee)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.