Last Comment Bug 243972 - css1 vertical-align has incosistent behaviour for <img> inside <button> if img has an align attribute
: css1 vertical-align has incosistent behaviour for <img> inside <button> if i...
Status: RESOLVED DUPLICATE of bug 50630
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://manolito.image.ece.ntua.gr/~si...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 12:36 PDT by Spiros Ioannou
Modified: 2004-05-18 14:50 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Spiros Ioannou 2004-05-18 12:36:11 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040517
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040517

css1 attribute vertical-align is ignored for the image inside the button if the
image has an "align" attribute, and has a strange placement below the text
regardless of the vertical-align value,depending if there is text before of the
image.


See the example. Correct behaviour is also shown.


Reproducible: Always
Steps to Reproduce:
Comment 1 Boris Zbarsky [:bz] 2004-05-18 14:50:25 PDT
align="left" floats the image.  So it's no longer inline, and vertical alignment
doesn't affect its positioning with respect to the line box.

Based on your screenshots, it looks like IE just ignores "align" on the image...
which would be a bug in IE, no?

The fact that having text before the float pushes down the float is bug 50630

*** This bug has been marked as a duplicate of 50630 ***

Note You need to log in before you can comment on or make changes to this bug.