openbsd claims broken code for ipv6 (IPv6 DNS specifically)

RESOLVED DUPLICATE of bug 68796

Status

--
major
RESOLVED DUPLICATE of bug 68796
14 years ago
11 years ago

People

(Reporter: josephb, Assigned: darin.moz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.6) Gecko/20040324 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.6) Gecko/20040324 Firefox/0.8

The below is from the ports update. Has this been corrected; should the OpenBSD
port be updated?

CVSROOT:	/cvs
Module name:	ports
Changes by:	pvalchev@cvs.openbsd.org	2004/03/06 00:51:27

Modified files:
	www/mozilla/patches: patch-nsprpub_pr_include_md__openbsd_h 
	www/mozilla-firefox/patches: 
	                             patch-nsprpub_pr_include_md__openbsd_h 
	mail/mozilla-thunderbird/patches: 
	                                  patch-nsprpub_pr_include_md__openbsd_h 

Log message:
disable IPv6 for 3.5 as it presents dns-resolution problems (and there is no time
for other fixes)
numerous people report success with this reverted.

Reproducible: Always
Steps to Reproduce:
1.Install Firefox from OpenBSD packages.
2. Run Firefox.
3. Attempt to get to IPv6 only or IPv6 mindful sites (www.kame.net, www.ipv6.org).


Actual Results:  
Resolution fails.

Expected Results:  
Resolve IPv6 domains.

Updated

14 years ago
Assignee: firefox → wchang0222
Component: General → NSPR
Product: Firefox → NSPR
QA Contact: wchang0222
Version: unspecified → other

Comment 1

14 years ago
Darin, could you look into this?
Assignee: wchang0222 → darin
(Assignee)

Comment 2

14 years ago
Lorenzo: any thoughts?

Comment 3

14 years ago
There's not enough information in this bug report for me to understand what the
problem is. Digging a little on the openbsd cvsweb, the diff is here:

http://www.openbsd.org/cgi-bin/cvsweb/ports/www/mozilla/patches/patch-nsprpub_pr_include_md__openbsd_h.diff?r1=1.3&r2=1.4&f=h

which shows that IPv6 was disabled. But the CVS comment doesn't say why, except
that "resolution fails" on IPv6 sites, and I can't find any reference to what
the problem was. This message:

http://archives.neohapsis.com/archives/openbsd/2004-05/1111.html

says "Mozilla's IPv6 support is broken.", but does not say why, which is not
very useful.

Reporter, can you do more digging in the openbsd community? In the absence of a
clear bug report, there's not much we can do here...
(Reporter)

Comment 4

14 years ago
I pinged the ports group to get the exact reason. I should hear back today.
(Reporter)

Comment 5

14 years ago
Here is the response, I believe this problem might have been resolved in later
0.8.* revisions (saw some bugzilla FreeBSD discussion [68796]).

"As far as I can tell, IPv6 support works fine per se, however,                
                                                                               
          enabling it causes an enormous slowdown in name resolution for some  
                                                                               
                   websites.  Some documents with lots of embedded images can
take a                                                                         
                              minute to load rather than just a few seconds. 
Just what is causing                                                           
                                         this, I don't know."
(Reporter)

Comment 6

14 years ago
Another quote form openbsd-ports people:

"Doubleclick is definitely a trigger, yes, as well as a couple other ad
servers that didn't answer AAAA either (don't remember off the top of my
head, but I'm sure I could find them if you're interested).  In
addition, I used the browser without ipv6 disabled for quite some time,
and whenever one tab hung, all the rest would as well until the first
timed out; more evidence pointing to serialized lookups?"

Comment 7

14 years ago
This really looks like bug 68796.

This has already been fixed in mozilla code by providing a pref to turn off IPv6
(which is all we can do).

When firefox 0.9 makes it into *bsd ports all users need to do is set the
network.dns.ipv4OnlyDomains to the domains they are having problems with (e.g.
doubleclick) or disable IPv6 completely by setting network.dns.disableIPv6 to true.

*** This bug has been marked as a duplicate of 68796 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.