Crash reloading gmail mailbox page

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: jst, Assigned: jst)

Tracking

({crash, regression})

Trunk
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
When logged into gmail, mozilla (trunk only) will crash if you reload the page.
This is a regression from the recent nsWyciwygChannel changes I made where the
wyciwyg channel now stores the data in the cache as UTF-16, and the channel
actually advertices its charset. This caused child-frames of pages that are
loaded from a wyciwyg channel to assume that their charset is UTF-16 (unless
otherwise specified in the http channel etc), and this exposed a bug in
nsScanner::Append() where it in this case didn't malloc a big enough buffer for
the data it was given (see bug 244177).

We should do two things here, we should make the scanner code not crash (by
fixing bug 244177), and we should also make a document not take the charset from
its parent if its parent is loaded from a wyciwyg channel since there's no
relation between their charsets any more, at all).
(Assignee)

Comment 1

15 years ago
Created attachment 148950 [details] [diff] [review]
Don't advertise the charset of a docshell that's loaded from a wyciwyg: URI (diff -w)
(Assignee)

Updated

15 years ago
Attachment #148950 - Attachment description: Don't advertise the charset of a docshell that's loaded from a wyciwyg: URI ( → Don't advertise the charset of a docshell that's loaded from a wyciwyg: URI (diff -w)
Attachment #148950 - Flags: superreview?(darin)
Attachment #148950 - Flags: review?(bzbarsky)
Comment on attachment 148950 [details] [diff] [review]
Don't advertise the charset of a docshell that's loaded from a wyciwyg: URI (diff -w)

s/advertice/advertise/ in the comment, and r=bzbarsky.
Attachment #148950 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 3

15 years ago
*** Bug 243639 has been marked as a duplicate of this bug. ***

Updated

15 years ago
No longer blocks: 243639

Comment 4

15 years ago
Comment on attachment 148950 [details] [diff] [review]
Don't advertise the charset of a docshell that's loaded from a wyciwyg: URI (diff -w)

sr=darin
Attachment #148950 - Flags: superreview?(darin) → superreview+
(Assignee)

Comment 5

15 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
*** Bug 243269 has been marked as a duplicate of this bug. ***
*** Bug 245368 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Severity: normal → critical
Keywords: crash
You need to log in before you can comment on or make changes to this bug.